2009 Macbook Pro 13 won't boot

Discussion in 'MacBook Pro' started by Michael2448, Jan 13, 2012.

  1. Michael2448 macrumors newbie

    Joined:
    Jan 13, 2012
    #1
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    So, I was sitting in the hall way, waiting for class to start, browsing the internet on my laptop.  Once the bell rang, I closed the lid of my laptop, walked inside my class room, and sat down.  When I opened the lid, the screen was black, but the "indicator light" on the front right corner was a solid color.  Occasionally my computer won't come back on (not too often, but enough to know that I've seen it before), so I held the power button down, waited to hear that "click", and attempted to turn it back on.  The computer attempted to turn back on, but after a little bit, the Apple logo disappeared, and was replaced with a circle with a dash through it.  The "wheel" on the bottom remained spinning.
     
    I didn't drop the computer, or make any abrupt movements, but I think it's the disk that died.  My main goal is just to get a solid "yes", it's only the disk, before I go and spend the money to replace it.  I didn't have any warning signs before hand that the disk was about to die.  I'm a Computer Science major, so I'm almost always on my laptop.
     
    I've tried resetting PRAM and SMC.  Single user mode and verbose mode both fail, usually with the last few lines something like:
    Code:
    [IOSATA WARNING: Enable auto=active failed.
    AppleAHCIDiskQueueManager::setPowerState(0xffffff800b897000, 2 -> 1) timed out after 100540 ms.
     
    I've tried booting into Lion's recovery partition, but the same thing happens.  Circle with a line through it.
     
    I've tried Snow Leopard upgrade DVD, but after 5 minutes or so, the screen freezes (DVD quits spinning), and the wheel stops mid circle.
    On the Leopard recovery disk that shipped with the computer, it freezes at a light blue screen.
    With the Lion recovery DVD I made.  The disk eventually loads, but the built in mouse and keyboard fail (both of which work in the boot loader menu (option on boot)).  If I use an external mouse, nothing happens when I choose a language to use.
     
    I purchased a Firewire cable earlier today, and I'm hoping to hook it up to my Mac Mini to see if I can get anything.  I just finished a program for one of my classes last night, and unfortunatly, my last Time Machine backup is about 2 days too old...
     
    Thanks for any help.
     
  2. mscice macrumors regular

    Joined:
    Aug 9, 2009
    #2
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    If you were jostling the computer around before the hard drive had a chance to park the heads, it could have incurred a crash making it useless at this time.

    given that you tried booting up the SL system disc, it may be something else.

    My recommendation is to schedule an appointment with an apple genius and have them work on it
     
  4. Michael2448 thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #4
    Will the Genius Bar cost anything to take a look at it? When I get home tonight, I'm going to try to take out the hard disk, and try to boot it then. Last time I had a hard drive go (a long time ago in a Windows machine), I couldn't boot from the CD drive either. I'm hoping that's all this is.
     
  5. Michael2448 thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #5
    I have an older (6 year or so) Toshiba laptop, with only a 60gb drive. If I plug that in, I can get the Snow Leopard disk to load, however, it doesn't recognize the hard drive. Is that simply because it's an older disk?

    Thanks for all of your help. It means a lot.
     
  6. NZed macrumors 65816

    NZed

    Joined:
    Jan 24, 2011
    Location:
    Canada, Eh?
    #6

    The cost to look at it is: free
     
  7. Michael2448 thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #7
    Okay, thanks. Tomorrow I'm meeting a friend and I'm going to borrow their Firewire cable to see if I can use target disk mode. I figure if I can access my Windows drive I'm borrowing through the computer, I figure the logic board is fine.
     
  8. Michael2448, Jan 13, 2012
    Last edited: Jan 13, 2012

    Michael2448 thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #8
    I actually got it up and running, but it's very sluggish. I didn't do anything different, it just loaded on one of the several attempts to start up. I've tried to open disk utility, but it fails to open ("Application not Responding" after "launching" for a minute or two).

    So, I ran the command "sudo fsck -f", and here is the results:
    So... Can we say this is simply a HD issue?

    Edit: I was able to get the Snow Leopard disk to load finally. Did a disk repair, but the system is still extremely slow.
     
  9. Michael2448 thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #9
    I took it to the Genius bar today. The guy seems to think it's the hard drive, everything checked out fine on the test. I purchased one on the internet today, so it should arrive soon.
     
  10. Michael2448 thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #10
    Just in case anyone has a similar issue, turns out it was the SATA cable. Thanks for the help.
     

Share This Page