2010 13" MBP Mouse skipping in WoW

Discussion in 'MacBook Pro' started by pricej636, May 2, 2010.

  1. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #1
    Hello,

    First of all, I did search and came up with nothing. Being a new computer, there really isn't a whole lot of information.

    Basically, I have a new 13" MBP. 2.4Ghz, 4MB Ram, basically a week old. Downloaded and installed WoW no issues until I started to play. My mouse, a Logitech Anywhere MX mouse skips when gameplay starts and basically becomes unusable. This is when I actually enter the realm and I try to walk around and play. When I start WoW and log in, the mouse does not skip, it is only during gameplay. The trackpad works fine. Did some testing, and the mouse skips when it is on the right side of the computer, or the opposite side from the receiver. When I have the mouse on the left side, or the same side as the receiver, the mouse works fine. When I am in firefox or anything else the mouse works fine on the opposite side of the receiver.

    Just to eliminate the mouse, I started WoW on my aluminum MB unibody, late 2008 model. The mouse does not exibit this behavior during gameplay. So this is specific to my new 2010 MBP.

    Any ideas?
     
  2. King Apple macrumors regular

    King Apple

    Joined:
    Mar 17, 2010
  3. pricej636 thread starter macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #3
    Logitech mouse skips. MBP Trackpad works fine. You didnt read what I posted.
     
  4. Dragonforce macrumors 6502a

    Dragonforce

    Joined:
    Apr 9, 2008
    Location:
    London (Ealing) UK
    #4
    Amazing reply. Try reading before answering.

    I have no idea whats wrong with your system or mouse, only idea that came up my mind is that the receiver is too far from the mouse to get a steady signal, but then it should happen all the time and not only in WoW.

    Its been quite some time that I've played WoW, but doesn't it have something like "use hardware cursor / mouse" and "reduce input lag" ?

    Try fiddling around with those 2 settings and see if it helps.
     
  5. matoch macrumors member

    Joined:
    Oct 12, 2006
    #5
    This may be a silly question but is there another wireless mouse nearby? I had issues with random skips on my mouse when a co-worker had a wireless logitech mouse on the other side of the wall. It took a while to pinpoint it because it was really only obvious when they used the mouse scroll wheel.

    Other then that my only idea's are as follows.
    1. Resync it just in case there is some issue there.
    2. Move the receiver closer or further away sometimes location can make a difference.
    3. If you have a corded mouse try it out to see if it encounters the same issues.

    Well I just re-read your post and saw that you said it's fine if your mouse is on the opposite side of the receiver. If you have a usb extension cable try connecting it to that and move the receiver further away. It's not a solution just another test unfortunately.
     
  6. pricej636 thread starter macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #6
    The mouse is fine in WoW if the mouse is on the same side as the receiver. If its on the opposite side it skips. But like I said, its only in WoW. Its almost as if either something is interfering with the signal from the receiver when the game starts, or something is lowering the output power from the receiver. I played with all the settings with no change. I even lowered video settings and effects but that didnt do anything either.

    I have a bluetooth mouse that I will try tomorrow.
     
  7. matoch macrumors member

    Joined:
    Oct 12, 2006
    #7
    There could definitely be something interfering with it. I seem to recall that I used to have my receiver sitting on top of my mac pro and at a distance of about 2 feet I had problems. I now have it set further away and I don't see that happening anymore.
     
  8. hypermog macrumors regular

    Joined:
    Nov 17, 2009
  9. ChocoboNL macrumors member

    Joined:
    Feb 20, 2008
    #9
    Older MBP, Older Mouse, Newer game, same problem..

    I play League of Legends every now and then on a 2009 MBP 13" with a Logitech VX Nano. Sometimes the mouse stops functioning altogether, not moving, no response from clicking, me dying, quiet annoying. ;) (These sort of things always tend to happen when you cannot afford to stand still :p)

    Anyway, my guess was that it was the metal frame of the unibody that interfered with the signal of the mouse (the laptop being in-between the mouse and the receiver). But perhaps it could also be the other mouse (Logitech MX Revolution I think, the somewhat older desktop mouse from Logitech). Or perhaps a phone.
     
  10. timothywin macrumors newbie

    Joined:
    Oct 3, 2010
    #10
    It has been quite some time now but I stumbled across this thread on google and I'm here to confirm that you're not crazy and that I have the exact same problem except this time with Starcraft 2. I'm using a Logitech m305 mouse (by no means a gamer mouse) but it is only skipping during SC2 and not during normal browsing.

    It's sporadic in its skipping. Very frustrating. There isn't any other wireless mouse within 15 feet of me, I'm using a mousepad, and I've tried about 4 different batteries.

    Could it just be that I'm more aware during the game than during browsing? Perhaps. Although in the height of my frustration I did test the reliability of the mouse before a game started and found that everything was fine. Once the game started, however, the mouse quickly became unstable.

    It's a shame considering that I just bought this mouse only to play this game. Now I have to go out there and buy another. This time I'm getting one that plugs in.
     
  11. DJ-R macrumors regular

    DJ-R

    Joined:
    Feb 17, 2010
    #11
    I have the same mouse as you.

    Did you have LLC (Logitech Software 3.3.0) installed?

    I have no issue with my wireless Logitech Anywhere MX mouse unless there are some heavy interferences going on around me.

    I also have a Logitech G5, very SAD I have USB Overdrive running it will still skip around because of the high DPI and buffer rate.

    This is a problem with OSX won't suppose any mouse with over 120 report rate.

    Most Logitech gaming mouse will have the same issue but not the Anywhere MX.
     
  12. deeesea macrumors 6502

    Joined:
    Aug 14, 2010
    #12
    My Logitech VX nano does some funky stuff when I'm playing LFD2 on bootcamp...or CSS on OSX. it likes to "play dead" for brief moments of time.

    I never figured out what was the issue, but if you guys have a solution I'd be interested to read about it. :)
     
  13. Smalss macrumors member

    Joined:
    Mar 31, 2010
    #13
    I had same issues with my Logitech MX Anywhere mouse. Tried downloading LLC software, didn't seem to work. It only doesn't work with WoW. Very frustrating.
     

Share This Page