2010 21.5' iMac Airport Problems

Discussion in 'iMac' started by jsf8x, May 18, 2011.

  1. jsf8x macrumors 6502

    jsf8x

    Joined:
    Feb 28, 2010
    #1
    Hi,

    I have had the base 21.5' since last December and I have absolutely loved it. However, the past couple of days I have had serious problems with the wireless. My computer connects to it but the loading times are ridiculously slow and sometimes it just attempts to load for up to 30 minutes and then times out. I know its not anything with the internet because everything works fine on my macbook as well as my phone and xbox. Any tips?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Maybe it's on the edge of its range. Move it closer to the access point.
     
  3. haganaga macrumors member

    Joined:
    May 20, 2010
    #3
    Hey folks,

    I'm bumping this up because I'm having the same issue. I have a base model 21" imac I got April 2010 that's having wireless issues. I'm sure it's internal on the imac and not the network. I have a airport extreme that's working fine with other devices. Even put the airport express near the imac to extend the network to make sure it isn't that. It's less than 30 feet from the extreme anyway but even with the express extending the network to 4 feet from the imac, it keeps going in and out. Anyone have a fix for this or am I doomed to take it into the apple store for repairs?

    Thanks!
     

Share This Page