2010 iMac 27" Video issues

Discussion in 'iMac' started by eljanitor, Dec 5, 2011.

  1. eljanitor macrumors 6502

    eljanitor

    Joined:
    Feb 10, 2011
    #1
    I'm having a recurring problem on a 2010-27 inch iMac and I was wondering if anyone has had this issue before. After a few hours of running one half of the display starts ghosting images. This had happened before and it was taken to Apple who replaced the logic board saying it was a video issue.

    Well its doing it again now. It doesn't matter if you switch user accounts, so its not corrupted software. The machine has all kinds of odd issues like dropping connections to printers, and dropping external hard drives. One day the external hard drive was working the next day it was shot. So I'm kinda concerned that this machine is taking out peripherals.

    One printer and one external hard drive down. Plus it gets real picky about option booting sometimes it will recognize an external boot drive and then next restart it cant find it, however another machine will pick up on it every time. So bad logic board number two?

    Any ideas?
     
  2. Laststop macrumors newbie

    Joined:
    Aug 7, 2011
    #2
    Hopefully your peripherals are under warranty still. Looks like the only thing you can do is make 3 phone calls. one to apple, one to printer company, one to hdd company and send em all in for replacement or repair. Now if the peripherals are working on all other computers then its obviously just your computer and you'll probably have to send it back to apple again.
     

Share This Page