2010 iMac OWC SSD not recognized after clone

Discussion in 'iMac' started by 006, Jun 29, 2017.

  1. 006 macrumors newbie

    Joined:
    Dec 14, 2010
    #1
    2010 iMac 11,3 10.6.8

    I have been getting OS GUI freezes randomly so I ran AHT and it kept giving me codes all related to the HDD: temp sensor and fan. Researched issue, most all solved by replacing the drive with an SSD.

    •Purchased this kit from Mac Sales/OWC, as well as a SATA>USB adapter cable.
    •SSD kit and cable arrived, I connected the SSD externally via adapter cable, formatted as Mac OS Extended (journaled) and GUID partition map using Disk Utility.
    •Cloned my HDD to the SSD using Disk Utility under the restore tab for the SSD, setting HDD as source and SSD as destination. Process completed in 3-4 hours.
    •Rebooted the iMac while holding option, all drives showed up, I selected the SSD. Booted fine, everything worked, unmounted HDD to check further, everything was still working.
    •Power down iMac, swapped the drives internally. Boot the iMac, greeted with flashing folder with question mark.
    •Reboot again holding option, no options except Internet Recovery.
    •Reboot again holding option, but this time with OSX Snow Leopard DVD image on a USB stick, it shows up but still no SSD - boot into Install DVD image, run Disk Utility, SSD does not show up there either.
    •Re-swapped drives internally, HDD internal, SSD external on adapter cable - works as before and both drives recognized on normal startup and while holding option on boot.

    So I have researched this and it seems fairly common. The most recommended solution is to replace the SATA cable, and for a lot of people this works. I have the part number and am willing to purchase and give that a shot. However, some people that encountered this issue tried booting from the HDD over USB and cloned the internal SSD from that before replacing the SATA cable, and it worked. I suppose I could try that first before having to tear apart the iMac further to replace the SATA cable, but I have no external HDD enclosure, a bit torn on what to do there - buy both, see which works, return what didn't?

    The other solution I have seen is exchanging the drive with the seller/manufacturer, sometimes this works as well, other times it does not.

    Another solution is that the firmware on the drive needs to be either upgraded or downgraded to a compatible version. I'm not sure how to find what firmware version is being used in the first place, let alone how/where to go beyond that to do anything about it if that is the case.

    Some (not many) reported success by doing a fresh install on the drive and migrating files over afterwards. I do not want a fresh install, some apps are a pain to re-authorize. I use this computer for audio production and need it cloned as-is, a fresh install is out of the question.

    I have sent an e-mail to OWC to see if they have any insight, but wanted to post here as well, the more the merrier as they say. Ideas?
     
  2. mbosse macrumors regular

    Joined:
    Apr 29, 2015
    Location:
    Vienna, Austria
    #2
    Did you try to install afresh and then migrate from a Time Machine backup?
     
  3. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #3
    Got the Snow Leopard DVD? Then boot from that, re-format the drive and do a clean install. Then migration Assistant to transfer things over. If that does not work out I suggest contacting OWC via their chat line.
     

Share This Page