2010 Mac Mini Ethernet DOA [SOLVED]

Discussion in 'Mac mini' started by wpc33, Oct 8, 2010.

  1. wpc33 macrumors 6502

    wpc33

    Joined:
    Jul 2, 2006
    Location:
    Vancouver, BC
    #1
    When my 2010 Mini arrived, I cloned my boot disk from my '09 Mini, and started from that.

    Everything worked perfectly, except the Ethernet. Network prefs wouldn't even detect the cable plugged in, when it worked perfectly on my '09, and my G3 Powerbook.

    I found a thread on the support.apple forums that the 2010 Mini ships with a specific build of OS X that is the only way to have the ethernet function.

    I re-installed SL from the '10's factory restore disk, and the Ethernet worked.
    Using Apps/Utilities/Migration Assistant after the fact was as thorough and smooth as I was always afraid it wouldn't.

    Just thought I'd share, because I spent many hours doing every reset, every standard troubleshoot, before discovering the answer.
     
  2. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #3
    From what I understand the reason for this is that the 2010 Mac mini uses a new combined controller chip for the Ethernet port and the SD Card slot. Previous models didn't have the SD Card slot and consequently had a different controller chip.
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #4
    Goes to show that attempting to install a version of OSx that's earlier than the one shipped with your Mac may not always work. New hardware often needs new drivers and such and only the version shipped with the machine and later versions will have the correct drivers.
     

Share This Page