2010 Mac Pro - Desktops stuttery with ML

Discussion in 'OS X Mountain Lion (10.8)' started by netnothing, Jul 25, 2012.

  1. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #1
    I'm running a 2010 Mac Pro....16GB of RAM, with the upgraded ATI 5870 card. Since upgrading to ML this morning, generallly performance is on par with Lion....however, switching between desktops (I have 8 setup) is not smooth at all.

    I'm wondering if others with a Mac Pro are seeing this as well?

    I know us Mac Pro users are bottom of the barrel in Apple's eyes....but I feel that overall system UI performance is worse for me in ML than Lion.

    -Kevin
     
  2. ooans macrumors 6502

    Joined:
    Jun 4, 2011
    #2
    I'm having the exact same problem. The funny thing is that I'm running the slowest 2010 MBA (with 4GB ram.)

    Hopefully this means that this is a more or less universal problem with older macs, and that it will be fixed...
     
  3. stiwi macrumors regular

    Joined:
    Nov 13, 2010
    Location:
    Singapore
    #3
    Mac Pro 2010 12GB, Westmere 3.33Ghz, 5770 card same issue.
     
  4. mabaker macrumors 65816

    mabaker

    Joined:
    Jan 19, 2008
    #4
    The same issue on the MBA 2010 with Nvidia graphics.

    Everything is butter smooth EXCEPT when changing spaces upon clicking an app. If you go to the full Mission Control view, however, you can change spaces easily without stuttering at all.

    Must be a software issue as on my Mini 2009 all the transitions are very smooth.

    Both installs were upgrades.
     
  5. netnothing, Jul 26, 2012
    Last edited: Jul 26, 2012

    netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #5
    Same here with the going to Mission Control first.....no stutters. Only when clicking icons in the dock or CMD + Tabbing between apps.

    -Kevin

    ----------

    Also notice stuttering when I go to do a selection screenshot:

    CMD + Control + Shift + 4

    The crosshairs that popup with the coordinates are stutterey as I move the mouse.

    -Kevin
     
  6. fb0r macrumors newbie

    Joined:
    Jul 26, 2012
    Location:
    Sweden
    #6
    I also have a 2010 MBA (13" BTO) and get the same stutter when switching desktops. I posted this in another thread already but try hiding the dock and desktop switching should be much smoother. I think there is an issue with the rendering of the new dock and graphics drivers for older Macs that is causing slowdowns...

    Cheers, fb0r
     
  7. mabaker macrumors 65816

    mabaker

    Joined:
    Jan 19, 2008
    #7
    Does it stutter if you change the dock to 2D? HEre: http://www.eternalstorms.at/utilities/2dornot2d/page45/page45.html
     
  8. fb0r macrumors newbie

    Joined:
    Jul 26, 2012
    Location:
    Sweden
    #8
    I tried putting the dock on the left (the way I prefer it on my 11" MBA) which makes it 2D and it definitely helped with the stutter. I think it's the fancy shiny silver rendering of the default ML dock that is messing with older drivers... Hopefully a fix/tweak of the nVidia drivers is due in an upcoming ML update.

    Cheers, fb0r
     
  9. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #9
    No real changes for me when hiding the dock OR putting it on the side.

    I might be seeing things....but I think Mail.app is contributing to the stutter when switching. When I have Mail open....the stutter is slightly worse. When I close Mail...it seems it gets a little better...not great though.

    -Kevin
     
  10. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #10
    Created a new user and tested the Screenshot flickering....same thing.

    Same choppiness on switching Desktops as well.

    -Kevin
     

Share This Page