2010 MacBook Air not charging.

Discussion in 'MacBook Air' started by jamets515, Nov 2, 2011.

  1. jamets515 macrumors regular

    Joined:
    Mar 23, 2011
    Location:
    Gloucester, UK
    #1
    I was wondering if I could get some ideas from the wider Mac community...

    All of a sudden, my MBA won't charge from the magsafe adaptor any more. I've tested it with my brother's magsafe and it doesn't charge from that either, although it works fine with his MBP.

    I've done an Apple Hardware Test which came back with no faults found and I've reset the SMC with no results.

    It has not suffered any physical damage and does not get used that much. It even still has that lovely 'new mac' smell lingering about it. It's still got about 25% charge left in it and I have given up tinkering with it for now. I want to leave some juice in it for when I go to the Genius Bar tomorrow.

    Before I go there tomorrow, I'm just wondering if anyone has any ideas of what might be wrong?

    Thanks.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    If The MagSafe Is Working


    Then it sounds like you might have an issue with the pins...Not something you can tackle so take it in and let them look at it.....If you can, backup all your stuff just in case they decide to wipe it, although I doubt they will.....Those little pins shouldn't bend, that's why they designed the MagSafe the way they did.

    Either way, hopefully they will sort things out for you.
     
  3. wrinkster22 macrumors 68030

    wrinkster22

    Joined:
    Jun 11, 2011
    Location:
    Toronto
    #3
    backup your data, you likely will get a refurb.
     
  4. jamets515 thread starter macrumors regular

    Joined:
    Mar 23, 2011
    Location:
    Gloucester, UK
    #4
    Thanks for the input. I'll post the outcome tomorrow after my appointment. Fingers crossed for a generous genius!
     
  5. jamets515 thread starter macrumors regular

    Joined:
    Mar 23, 2011
    Location:
    Gloucester, UK
    #5
    Okay. They said they're going to replace the logic board, I/O board and I/O flex within 5-7 days. We'll see how It goes.
     
  6. jamets515 thread starter macrumors regular

    Joined:
    Mar 23, 2011
    Location:
    Gloucester, UK
    #6
    Just got it back this morning and its not working again. I tried it with their MagSafe adapter from one of the demo MBP's and it worked. Tried it in mine and the thing stopped charging again after about 10 minutes. Found some scratches that weren't there as well. I phoned the store and was on hold for about 20 minutes before giving up. Should I bother calling them or just take it back?

    I'm guessing it must be my adapter and not the MBA.
     
  7. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #7
    if the adapter works in other computers then i can't see how it might be it.


    take it back, complain about the newly found scratches, the charging problem and the possibility of yet another week without a computer.

    you should really negotiate for a new machine, me thinks.

    i would be surprised if Apple doesn't see it this way also. That is part of the reason why you bought their products in the first place. Sony would give you a sympathetic smile and a new invoice.
     
  8. jamets515 thread starter macrumors regular

    Joined:
    Mar 23, 2011
    Location:
    Gloucester, UK
    #8
    To cut a long story short (I went back a few times) I spoke to the genius that worked on my mac. Although not a conclusive answer, he suspected something was shorting across the top case. They gave up with mine and swapped it out for an i5.
     

Share This Page