2010 Macbook Pro WiFi problem

Discussion in 'MacBook Pro' started by Mikey86uk, Nov 13, 2011.

  1. Mikey86uk macrumors 6502

    Joined:
    Jul 3, 2010
    Location:
    England
    #1
    Hi Guys

    For some reason my MBP 13" cant find my wireless network, but then sometimes it does, but ive tried resetting my router etc and still cant find it at this moment :confused:

    Funny thing is my new iMac can find it and connect with no issues at all :confused:

    Both Macs are running Lion fully updated.

    My Router is a D Link DIR 655

    Anything im missing?

    Thanks for any help!
     
  2. Mikey86uk thread starter macrumors 6502

    Joined:
    Jul 3, 2010
    Location:
    England
    #2
    Hi Guys

    As i didn't get a reply last time :( i thought i would do a clean install of Lion, which worked up till a about a week ago, and now my MBP has gone back to its old ways :(

    Sometimes it will connect for a while and be fine, sometimes it loses connection every 5 or so minutes, or it will scan for wireless networks and find every router in the area apart from my D Link :confused:

    Im sure it isnt the router as my iMac has no issues.

    There has to be someone on this great forum who has had this issue and found a fix or knows of a fix?

    Many Thanks
     
  3. dontwalkhand macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #3
    I have had issues with routers before, and it will keep some clients connected, while some clients get disconnected. Does this happen at another Wi-Fi hotspot, such as a coffee shop or something?

    If this doesn't, then you know its the router. If it does, then it's time to make a Genius Bar appointment.
     
  4. uvisto macrumors newbie

    Joined:
    Jan 7, 2012
    #4
    MacBook Pro wireless issues

    I've got a 'newish' (July 2011) 13" MBP, it started to lose connectivity not long after I started using a new a time capsule about 2 months back, it's very annoying but not the end of the world, I was thinking of getting an airport extreme to help me out. I'm not sure if the time capsule has anything to do with the issue, but I don't recall the issue before.
     
  5. MaxPower72 macrumors 6502

    MaxPower72

    Joined:
    Aug 15, 2012
    Location:
    Chicago, Illinois, Crooks County
    #5
    I have the same issue with my 2010 MBP 13" while the 2012 MBP 13" has no problems at all using WiFi at home. THey both keep scanning for new networks
    but the 2010 seems to loose the signal for 10-15 seconds at the time then reconnect and repeat this cycle endlessly making internet navigation slower.

    Is it the airport card? needs to be replaced?
     

Share This Page