Resolved 2010 MBP GPU running hot while hooked to cinema display - Why can't I use HD3000?

MathiasVH

macrumors regular
Original poster
Nov 7, 2009
146
4
Hi guys :D

I've just purchased a Cinema Display. I love it. My MBP is, however, running a bit too hot to my liking. I'm sure it's because of the GPU kicking in and the worsened fan effectivity by running in clamshell mode.

I thought: "Well, the solution is easy, I can just force integrated graphics on using gfxCardStatys", but when I do that, the MBP disconnects from the CM.

I know that the Mac Mini has no problem whatsoever with using HD3000 with a cinema display, so I wonder if you know how I can use my HD3000 without the MBP disconnecting?

Thanks in advance! :D
Mathias
 
Last edited:

iMacDragon

macrumors 68000
Oct 18, 2008
1,751
296
UK
Hi guys :D

I've just purchased a Cinema Display. I love it. My MBP is, however, running a bit too hot to my liking. I'm sure it's because of the GPU kicking in and the worsened fan effectivity by running in clamshell mode.

I thought: "Well, the solution is easy, I can just force integrated graphics on using gfxCardStatys", but when I do that, the MBP disconnects from the CM.

I know that the Mac Mini has no problem whatsoever with using HD3000 with a cinema display, so I wonder if you know how I can use my HD3000 without the MBP disconnecting?

Thanks in advance! :D
Mathias
Because the hd3000 only has a physical connection to the internal screen. All the MBP's are like this since switch to intel + dedicated gpu.