2010 MBP Won't Boot!

Discussion in 'MacBook Pro' started by jkuz, May 21, 2012.

  1. jkuz macrumors newbie

    Joined:
    Apr 18, 2011
    #1
    Hey guys,
    I have a 2010 MacBook Pro 2.6Ghz i7
    I have been running Snow Leopard since I got it and I refuse to use Lion. (For many a reason.)

    Me trying to have a contingency plan, made a second boot drive. Which was useful because my original drive had crashed later and I put the backup into my MBP and booted from it and was back up and running in minutes. It was fantastic.

    The second hard drive that I had was a tiny 160GB so I knew I would need to buy a new 500GB at some point to move back to, and that is what I just did and now I am having issues. I bought a Seagate Momentus XT drive. (500GB with 4GB of solid state memory.) I don't believe the issue is with the drive, but I will get to that soon enough.

    I tried to boot my MBP from a retail version of SL and (using verbose mode) I watch it try to boot until it gets stuck at the what I believe is the Kernel. It will not progress any farther even if I let it sit for hours. I tried to boot from the SL disk on my MBP, a co-workers Lion MBP, and a Lion iMac. None of them would boot the from the disk. So I thought that maybe Apple was being Apple and would no longer support booting from SL disks. (A ploy to get you to move to lion maybe?) So I found a SL iMac at work and I booted from the disk on there and installed SL on my hard drive from an external firewire enclosure. It installed SL successfully and I was able to boot the iMac from the hard drive I just installed SL on. (Which is why I don't believe the Momentus XT drive is bad.)

    Then when I put the hard drive back into my MBP I would boot my computer (using Verbose mode) and would watch it get stuck at a similar spot that the SL disk would get caught up on. It would not boot and I am completely clueless on what is wrong.

    If I put the 160GB hdd into the MBP and boot the computer it will be perfectly fine and boot successfully. Additionally I have tried booting the computer with the 160GB drive and installing SL on to my new drive but that didn't work either. I'll try with a USB copy of SL tomorrow but until then I am baffled.

    Any suggestions on what I need to do or what the issue is????
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Your Mac shipped with gray install DVDs of a special build of 10.6.3 or (later) 10.6.4. A retail 10.6.3 disc does not have the build of OS required to be able to run the system and to properly recognize all of the internal components and devices. Before you tried starting your MacBook Pro off of the 500 GB drive after installing 10.6 on it through the iMac, did you update it to 10.6.8? Update it to 10.6.8 through Software Update, then install it into the MacBook Pro and try booting off of it, and it should work.
     
  3. jkuz thread starter macrumors newbie

    Joined:
    Apr 18, 2011
    #3
    I didn't update it on the iMac. I will definitely try that tomorrow and see if it helps.
    It wouldn't be that the OS is hardware specific to an iMac v MBP? Like a compilation difference.
     

Share This Page