2011 15 " MacBook Pro - Cannot bootcamp w/ SSD

Discussion in 'MacBook Pro' started by CompanionCube, Mar 6, 2011.

  1. CompanionCube macrumors regular

    CompanionCube

    Joined:
    Aug 3, 2009
    #1
    Has anyone here successfully bootcamped their 2011 15" with an SSD? I tried it last night and it bricked the drive. I had to remove it, and wipe it clean with Intel's SSD Toolbox (it's an X25-m 120gb G2).

    After I partitioned the drive, and restarted the mac, the only drive it would see is the Bootcamp partition and it would just hang at startup and show a folder icon with a ? in the middle.

    It would never actually boot from the DVD or anything. I'm running the SSD in the HDD location too.
     
  2. wct097 macrumors 6502

    Joined:
    Nov 30, 2010
    #2
    Mine worked fine with the factory SSD. 2011 15 2.2 AG 128SSD 8gb.
     
  3. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #3
    How old is the X25? There is a known issue with early X25 SSDs that prevent bootcamp from working.

    It's mentioned at the bottom of the page here:
    http://www.anandtech.com/show/2742
     
  4. IonBlade macrumors newbie

    Joined:
    Mar 6, 2011
    #4
    I spent all day yesterday bumping into the same problem on an X25-m G1 80GB. Unfortunately, there's no fix for my particular model.

    Good news for you though - from what I read on some forums (sorry, hit up about 100 links yesterday, and I can't seem to find it again), the 120 GB's latest firmware update fixes Boot Camp issues.

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18363

    You'll get an ISO that you then need to burn to a disc. I don't believe it'll boot in a Mac, so you'll have to pop the drive into a PC, boot from that disc, and run the update. After that, you should be good to install Boot Camp.
     
  5. CompanionCube thread starter macrumors regular

    CompanionCube

    Joined:
    Aug 3, 2009
    #5
    Thanks for the replies guys. It's a new G2 120gb unit, I did do the firmware update AFTER I removed it and used SSD Toolbox to wipe the drive and start over. Now I'm kind of afraid to try it again after that ordeal yesterday. Maybe if I feel brave enough I'll try again.
     

Share This Page