2011 15" MBP flakiness -- need advice

Discussion in 'MacBook Pro' started by dartboard, Mar 3, 2011.

  1. dartboard macrumors newbie

    Joined:
    Mar 3, 2011
    #1
    So, I'm loving my new 15" MBP. Got the higher-end model with the hi-res screen. Gorgeous. Am having lots of little flakiness issues though, I'd consider them maybe growing pains but in 24 hrs I've probably had the machine lock up outright at least ten times.

    Some of the lock ups seem like they might be due to immature drivers (for example, changing the video mode in Starcraft 2 settings will lock the machine up every single time). OK, maybe a quick OS update in a few weeks will take care of this issue. Anyone else have this problem?

    Other things seem to be related to general load. I was downloading a few torrents (Transmission), backing up to my time machine over wireless, building Deluge (bittorrent client) using macports, and running Eclipse (Java development), and the machine locked up. Mouse cursor moves, fans are humming, but no windows respond.

    I'm not sure what the temperature was, but I can run 8 processes at 100% and the CPU hovers at 87C/187F -- no higher. The system seems stable for extended periods during these tests, so I doubt it's simple overheating.

    Any suggestions for isolating the problem? I'm not super close to an Apple store so I'd hate to bring it in only to have them not be able to replicate the problem.

    db
     
  2. fr4c macrumors 65816

    fr4c

    Joined:
    Jul 27, 2007
    Location:
    Hamster wheel
    #2
    Have you tried the basic troubleshooting steps? (Repair permissions, run Software Update, PRAM reset, etc.)
     
  3. a.y.n macrumors regular

    a.y.n

    Joined:
    Jul 7, 2009
    Location:
    San Francisco
    #3
    Did you migrate (via migration wizard) from another Mac or set it up new?
     
  4. dartboard thread starter macrumors newbie

    Joined:
    Mar 3, 2011
    #4
    Thank you guys. I had not tried a PRAM reset, did that. No software updates pending. Did repair permissions a few times over the last two days. Seems like it always finds issues - new ones each time, but immediately rerunning yields no new issues.

    It is migrated from another Mac.:eek: There were issues that took some manual cleanup. My username was transposed with my wife's from the old machine. Permissions wonked but I think I fixed those issues. I suppose this could certainly be some/all of the issues.

    Maybe I'll just bite the bullet and do a clean OS install. Otherwise I'll never truly know unless it magically resolves itself after some update.
     
  5. TheHoff macrumors 6502

    Joined:
    Oct 22, 2008
    #5
  6. dartboard thread starter macrumors newbie

    Joined:
    Mar 3, 2011
    #6
    I ran extended diagnostics and nothing turned up. So, I wiped the partition and reinstalled OS X from scratch. First thing I installed was Starcraft 2 and after an hour of downloading patches, I finally got in the game. Go to Menu and try to modify graphics options and select the native panel resolution (1600x1000 or something) and the screen goes black and never comes back. Sound continues (even other apps, a torrent completed downloading while screen was "off") but otherwise I can't do anything.

    I wonder if anyone else can successfully change the resolution in Starcraft 2 on a 15" 2011 MBP with Radeon 6750?
     
  7. Kevenly macrumors regular

    Kevenly

    Joined:
    Nov 22, 2008
    Location:
    The wrong planet.
    #7
    Have you tried turning off automatic graphics switching? I have to turn that off to avoid problems with anything that uses full screen graphics, namely games.
     
  8. dartboard thread starter macrumors newbie

    Joined:
    Mar 3, 2011
    #8
    OK, so this was confusing me because it was two separate issues that seemed loosely related. Turns out, two separate issues that were unrelated.

    First, a reinstall of OS X and manual migration of specific profile elements resolved the miscellaneous load-related lock-ups. Great!

    Second, disabling automatic graphics switching resolved my issues with Starcraft 2. Also great!

    Thanks everyone.
     
  9. Reclaim3r macrumors regular

    Joined:
    Jul 15, 2009
    Location:
    PA
    #9
    I have had Starcraft lock up on me twice on OS X as well... both times occurred when I messed with video settings. I also have the high-end 15", but low-res screen. I was able to get the resolution to native, but it took two attempts.
     

Share This Page