OS Neutral 2011 iMac and Gaming

MikeM87

macrumors 6502
Original poster
Jun 24, 2010
266
6
UK
Hi,

I have a 2011 Imac and would like to play a few games and am just wondering how it will handle them.

Also would it be best to use bootcamp?

I was looking to play the sims 3 to start with.

Spec is as follows:

21.5-inch: 2.5GHz
2.5GHz Quad-Core Intel Core i5
1920 x 1080 resolution
16GB of Ram
500GB hard drive1
AMD Radeon HD 6750M with 512MB

Thanks for any input!
 

Hastings101

macrumors 68020
Jun 22, 2010
2,118
740
K
It should run without any problems in Mac OS X :). The Windows version works a little better in my opinion but not a necessity.
 

Nightarchaon

macrumors 65816
Sep 1, 2010
1,393
29
I use a 2011 iMac, the 21" model up from the base model, runs all games fine in bootcamp, including skyrim and other modern games all at native resolution.

although i mostly play starwars the old republic in a parallels virtual machine, so i don't have to keep re-booting and can drop in and out of the game whilst working on other things.
 

leebrendalee

macrumors newbie
Feb 2, 2010
7
0
I am able to play stars mmo no problem with parallels 8! Super thrilled. I even got the mouse problem fixed. I'm totally able to do flashpoints, raids, everything and I'm the healer so I cannot have anything wrong.

Super stoked!!

My specs:

10.8.1
3.4 GHz Intel Core i7
Memory: 16gb 1333 MHz ddr3 (yes when I ordered it I wanted the best ram)
and the new Mountain Lion
I think I got the highest ram on the video card also.

I'm using Razer mouse and Keyboard,
 

PaulKemp

macrumors 6502
Jun 2, 2009
452
45
Norway
Hi, just though i should post here to maybe get some feedback.

Just installed bootcamp and windows 8. Installed direct x 11 and Skyrim. I aslo installed the AMD Catalyst 12.9 beta drivers (seems new and does support the 6950 (?) card.

I have the top specced iMac 2011 but with 1 gb gpu ram on the video card..

When running Skyrim I get very low fps. Around 15/20 maybe. Thats with medium settings, native resolution on the 27", medium texture and low on everything else. No AA or AF. Is this normal? I was expecting more to be honest.

edit: I actually had to set everything to low and a low resolution to make it playable. So obviously something is wrong. I'll try with 3d mark and another game.

edit: Tried in Windows 7 - smooth as a deer skin!
 
Last edited: