2011 imac wont stay asleep; weird noises

Discussion in 'iMac' started by xkmxkmxlmx, May 26, 2011.

  1. xkmxkmxlmx macrumors 6502a

    xkmxkmxlmx

    Joined:
    Apr 28, 2011
    #1
    2011 27" 3.1ghz core i5

    First off, when it does power down to go to sleep (screen starts to dim) you can hear the HDD spin (maybe preparing to sleep as well?). Never had this problem with my *silent* 2007 imac.

    Secondly, it won't stay asleep. I have not timed the intervals as of yet, but I would say it powers itself on out of sleep every half hour or so? I started to notice when I would wake up in the morning or come home from work and it would be on.

    Lately, I have had some time around the house and actually witness it coming on. When it does, it makes 3 loud click noises (again, sounds very much like the HDD) at about 3 seconds in between them. Then it wakes and you hear one more similar click.

    I have no running processes other than the stock ones. I have no running apps. I have also checked and unchecked stuff like "wake on network access", etc, with no luck. And even if it was a network problem, it still doesn't explain the HDD noise.

    I have also looked at the SMART status and it is verified. I checked it in disc utility as well and it all checks out. I have not ran an Onyx system scan yet, but I will probably do that next.

    Any other ideas?
     
  2. flipster macrumors 6502a

    Joined:
    Mar 14, 2010
    Location:
    Boston
    #2
    Check the terminal logs, report back with what they say.
     
  3. iDabble macrumors regular

    Joined:
    Jun 24, 2010
    #3
    My 27" 2.7ghz wakes up from sleep on it's own as well...really obnoxious because it lights up my whole room at night
     
  4. Statelymwhite macrumors regular

    Joined:
    Apr 1, 2011
    #4
    Mine has done this somewhat randomly, but one thing that always jars it from sleep is if I turn the printer off while it's sleeping. The printer is connected by USB cable. Perhaps there's a bug in the sleep routine that looks for any sort of activity, user interface or not.
     
  5. xkmxkmxlmx thread starter macrumors 6502a

    xkmxkmxlmx

    Joined:
    Apr 28, 2011
    #5
    I will when I get home. Thanks.
     
  6. xkmxkmxlmx thread starter macrumors 6502a

    xkmxkmxlmx

    Joined:
    Apr 28, 2011
    #7
    I forgot to say that I have also had everything disconnected except for my wired mouse and wired kb. No external hard drives, no printers, and turned blue tooth off.

    I have basically tried most everything on the apple troubleshooting page with no luck.
     
  7. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  8. pt0016 macrumors regular

    pt0016

    Joined:
    Jul 9, 2010
    #9
    Make sure wake for network access is not ticked in System Preferences, Energy Saver, and also that there are no outstanding print jobs in Print And Fax, as this may also cause it not too sleep
     
  9. iLidz macrumors member

    iLidz

    Joined:
    May 19, 2011
    Location:
    California
    #10
    Do you have any running applications? I've had my iMac for a few weeks now and didn't encounter a similar issue until a few days ago. The computer would wake from sleep for no apparent reason. I was able to track the issue down to running applications.

    Remember that hitting the red x on the upper left hand corner of an open app only closes it. I now always quit apps before putting my mac to sleep. After quitting any running apps my iMac's insomnia went away.
     
  10. fredou macrumors newbie

    Joined:
    May 21, 2011
    #11
    iLidz: The reason why you are using Sleep is because we don't want to close the applications and resume where we were.

    I also have this problem like many here and I've just checked logs in console:

    11-06-05 02:24:54 [0x0-0x41041].com.skype.skype[377] WirelessAttach: IOServiceOpen error: e00002c7


    It look like when I sleep with skype 5 opened, it is waking up during the night. I will test tonight with skype 5 closed to see if it does stay insleep mode.

    Also like someone here mentioned here, it is important to uncheck Wake up from Network access or something like this..
     

Share This Page