2011 Mac Mini Can't Restart

Discussion in 'Mac mini' started by shortcut3d, Sep 28, 2011.

  1. shortcut3d macrumors 65816

    Joined:
    Aug 24, 2011
    #1
    So I installed bootcamp and have a fully functioning HTPC however I can not restart the Mac Mini. Shutdown and cold boot are fine. Just restarting from Windows 7 results in a black screen. Windows 7 has successfully shutdown but does not seem to request a restart. No bong, just sits running with everything off (Bluetooth, USB, FW800, etc.). I have to manually power off and power on. Windows 7 does not complain. So far I reinstalled Windows 7, swapped RAM with know good Mac mini, tried after each driver. Formatted disk 0 via target disk mode - Thunderbolt with GUID partition table to ensure there is a healthy EFI partition.

    ----------

    Alt / Option key at boot does not work to switches OSes.
     
  2. flatfoot macrumors 65816

    Joined:
    Aug 11, 2009
    #2
    Sitting there with everything off plus a bong would be funny. :D

    Now seriously, that sounds strange...
     
  3. shortcut3d thread starter macrumors 65816

    Joined:
    Aug 24, 2011
    #3
    I have 2 identically configured Mac Mini's and one does not have this problem. I noticed that there was no EFI partition on the problem machine. I reformatted that drive using target disk mode to get an EFI partition. Then I did clean installs of Windows 7 x64 last night and the problematic one still exhibits the same behavior:

    - Hold Option (ALT) to get to the boot selector does not work. Hangs Windows boot.

    - PRAM reset (Command + Option + P + R) does not work.

    - Restart from Windows shutdown menu turns off bluetooth, network, WiFi, display, but the system is still on. Never makes it to the gray screen or bong.

    However,

    Shutdown and Sleep (S3) from Windows is working AND target disk mode works AND selecting Restart in Mac OSX from boot camp works.

    Very strange behavior. More of an annoyance, but I am concerned the EFI is hosed or failing.
     
  4. shortcut3d thread starter macrumors 65816

    Joined:
    Aug 24, 2011
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    I decided to enable AHCI in Windows 7. Not sure if AHCI solved the problem or if the registry mods did. Restart is working again. Not having Sleep is not a big deal since the HTPC is 24/7 because of tuner reliably.
     

Share This Page