2011 Mac Mini HDMI audio issues with TV

Discussion in 'Mac mini' started by PoppaJoe, Dec 12, 2011.

  1. PoppaJoe macrumors newbie

    Joined:
    Nov 21, 2011
    Location:
    California
    #1
    I have a 2011 Mac Mini (i7 server) that I connected to my 37" Olevia LCD HD TV. There is no problem with the video, but I can't seem to get the audio on the TV. I did a search but couldn't come up with any good solutions.

    1. I've selected HDMI in the Sound settings and selected the profile for my TV, but that doesn't seem to work.

    2. I know my HDMI cable is good since I can connect a PC to the TV and get both audio and video.

    Do you think there is something wrong with the mini? Do I have to get a receiver? Do I need to get a new TV (mine is 4 yrs old..)? Should I just get some speakers for the mini?

    TIA for your suggestions and advice.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Did you check the volume on both your Mac mini and the TV?
     
  3. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #3
    Does audio work in the OS at all when connected to the TV? I noticed a bug in the latest Plex release that makes the audio screwy if you manually select HDMI in its sound settings; has to be set to Default. Is your lack of volume app-specific?
     
  4. PoppaJoe thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    Location:
    California
    #4
    The volume on the mini and TV both fine. If I choose the mini for the alerts and sound, it works fine, but when I select my TV it is silent. Also, when I look at the output to make sure that the TV / HDMI is selected, it says, "The selected device has no output controls" and I can't control the volume.

    I don't think it is app specific since I'm using the Sound settings as well as iTunes to test the sound.
     
  5. rosemary1 macrumors regular

    Joined:
    Aug 9, 2011
    #5
    You need to go into Audio Midi Setup instead of the Audio Settings in System Preferences.
     
  6. Bye Bye Baby macrumors 65816

    Bye Bye Baby

    Joined:
    Sep 15, 2004
    Location:
    i(am in the)cloud
    #6
    Apple's audio management is not the most intuitive.

    Need both midi setup and audio preference pane set to indicate HDMI. Plus your tv may have a setting for audio input output.

    Try that
     
  7. PoppaJoe thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    Location:
    California
    #7
    Thanks for the suggestions. I tried the Audio Midi Setup - it shows 3 options, Built-in Input, Build-in Output, and HDMI.

    The HDMI shows my TV model under the Output setting, however, the volume bar is grayed out, and the Configure Speakers tab doesn't do anything.

    I'm going to test the mini on the weekend with a new Sharp Aquos LED tv.

    However, I'm getting the sinking feeling that I won't be able to have audio from the mini onto my TV via HDMI. I can't seem to find anything via a google search. It seems as if I will have to bite the bullet and look for a newer TV, an audio system, and / or a media client such as ATV, Roku, or Boxee.

    Looks like my quest for a HTPC/media center will be delayed. :(
     
  8. warvanov macrumors 6502a

    Joined:
    Oct 13, 2011
    #8
    Don't give up yet. This is a fairly common problem. Chances are the issue is with your Mac, not the TV, so don't expect a new TV to fix everything.
     
  9. rosemary1 macrumors regular

    Joined:
    Aug 9, 2011
    #9
    That's because the volume is controlled on the TV itself. Try again.
     
  10. PoppaJoe thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    Location:
    California
    #10
    I mentioned that it was grayed out just to point out that I'm still not getting any audio through HDMI even though I've set the Sound settings and the Audio Midi settings. My TV volume is turned to maximum and I still have no volume :(

    I'll bring it into the Geniuses at the :apple: store can help. That will help me determine if its TV or mini related. Though, I just tested my netbook pc and that is able to transmit video and audio through HDMI just fine. It's a bit disappointing since I expected a plug and play experience from :apple:.

    Just as I'm about to post this, I decided to try the settings again...


    My Audio Midi setup has 96000.0 Hz selected for the Format and 2ch-24bit Integer (default). I tried different combinations and now it works! :D I thought I had tested the multiple combinations of settings. Apparently I did not. Now, I don't have to feel like a doofus in person, only to all the anonymous forum readers, :eek: ;)

    Thank you all for your help and pushing me to keep at it. :p
     

Share This Page