2011 Mac Mini + OWC Electra SSD + Firmware Update Success?!?!

Discussion in 'Mac mini' started by archangel37, Feb 2, 2012.

  1. archangel37 macrumors member

    Joined:
    Apr 1, 2005
    #1
    Has anyone with a 2011 Mac Mini and a OWC Electra 6G SSD installed as their main HD had any success using the provided Mac or Windows software to update their drive's firmware?

    I've attempted to update two different drives in two different minis using both the Boot Camp/Windows OWC software and the Mac/Linux DVD software. Neither one worked.

    The Windows would report a successful update but NOT automatically reboot. A manual reboot later coupled with starting up the firmware update software would report the exact same firmware version. Despite the green check mark, the firmware would not update.

    I then tried the "Mac"/Linux DVD solution they offer. It will boot and show me the drive needs to be updated, but then report the firmware appears to be damaged and quit.

    Anyone under these circumstances have any success?
     
  2. Edge macrumors member

    Joined:
    Jul 28, 2005
    #2
    Mac mini 5,2 not listed as compatible

    I used the "Mac" OWC firmware updater on my i5 mini with discrete 6630M graphics (the Mac mini 5,2 model, which is not technically listed as compatible on the OWC SSD firmware webpage. Both the 5,1 and 5,3 models are listed, however.)

    My OWC SSD is the Extreme Pro 3G 240GB which had an early version of the firmware (not the Electra as in your case). But the "Mac" updater seemed to work, I got the green tick. But having read your post, I will now reconfirm that the firmware has actually been updated, after the SSD subsequently disappeared from the SATA bus in the Mac mini. I removed the drive and it is working in an external case, but I would not be surprised if the firmware actually failed to take. (I assumed the green tick meant it worked.)

    Which Mac mini model did you use for the updater?
     
  3. archangel37 thread starter macrumors member

    Joined:
    Apr 1, 2005
    #3
    I'm using the MacMini5,1, the model just below yours, with integrated graphics. I can only assume your firmware actually updated, as I couldn't even get the green check mark using the "mac" updater. I tried using another DVD burnt using Toast instead of Disk Utility on another mac, and that failed in the same "Firmware appears to be damaged, please shut down and try again" fashion. Multiple restarts didn't help.

    It appears Electra SSDs don't like MacMini5,1. Or I just have some awful luck. Off to OWC she goes...

     

Share This Page