2011 Mac Mini Won't Boot From Internal HD

Discussion in 'Mac mini' started by aidanpendragon, Apr 1, 2016.

  1. aidanpendragon macrumors 6502a

    Joined:
    Jul 26, 2005
    #1
    My 2011 Mac Mini (Core i7) has worked reliably for years, but just started refusing to boot from the internal HD. Appreciate thoughts on what I should do next, and whether this is a hardware or software problem (fearing the former, hoping the latter).

    Background: HD is a Crucial M4 SSD that I had an AASP install in late 2012 when I bought the gently-used Mini. OS is 10.8.5. I recently moved the Mini about 5 feet from its old spot in an attempt to run it as a headless media server, so turned on Screen Sharing/Remote Desktop and (initially) didn't have a keyboard or mouse attached. It is plugged into my TV via HDMI, and now has a keyboard/mouse connected too.

    Short story: Machine still boots from the recovery partition or external HDD, and can see & back up data on the internal OS X partition, but can't boot from it or the Bootcamp partition. Disk Utility and NVRAM resets haven't fixed the issue. Haven't tried an OS X reinstall yet.

    Details:

    #1. On pressing the power button, the gray-background boot screen and gray Apple logo come up. There also is the spinning round status indicator below the Apple logo, that just keeps spinning. I have to hard-power off the system by holding the power button. This started happening occasionally and now happens every time I start it up.

    #2. If I hold option, the boot volume selector screen comes up. I can see my OS X partition, as well as my Bootcamp partition (Win7) and Recovery OS X partition (and my backup FW 800 external HDD, if attached). But if I choose my internal main OS X partition, same gray nothing as #1, above.

    #2b. The Mini won't boot into Windows via Bootcamp, either. (Sometimes I get a flashing white C prompt-type cursor in the very upper-left corner of an all-black screen, and once the Win7 green loading bar appeared, but in no cases has it booted.) Not sure if this indicates a HD problem or if Bootcamp is tied into the OS X partition somehow.

    #3. If I boot from my backup HDD, I can see the internal OS X partition and all the files, and copy them to the external HDD. So, all the data (for now) appears intact.

    #4. If I boot from my Recovery partition or backup HDD, and try to select a startup volume, my OS X partition doesn't even show up, only my Bootcamp partition and external HDD. However, the first time I tried this, I could see my main OS X partition, but got the error message: "the bless tool was unable to set the current boot disk."

    #5. Disk Utility shows no problems when I verify the OS X partition. However, when I try to repair it, I get the error "Error: Couldn’t unmount disk." SMART status is Passed.

    #6. When I try to repair permissions on the OS X partition, I do get one out-of-the-ordinary error, presumably tied to turning on Screen Sharing/Apple Remote Desktop: "Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent” has been modified and will not be repaired."

    #7. As mentioned up top, I physically moved the Mini about 5 feet away to hook it into my TV and HD DVR. So, it's been physically moved before this problem started, but not at all jostled. I also opened the bottom hatch to blow out any dust bunnies. RAM is properly seated and registers OK when booted.

    #8. I tried resetting the NVRAM, and got the appropriate double-chime/restart feedback, but no effect.

    What Haven't I Tried: I haven't yet done an Archive and Install or fresh install.

    Appreciate your thoughts on next moves. I'm guessing a system reinstall might be the next step? Anything else I can do short of that to "bless" the HD (or the OS X equivalent?) The fact that the machine boots, shows the OS X volume, and lets me pull files off it makes me hope this is not a hardware problem. Could turning on ARD/Screen Sharing be causing an issue? (I can't imagine how but who knows given the Disk Utility results).

    Thanks.
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    Backup important files if you do not have a recent backup.

    I would then recommend Disk Warrior to repair your directory, unfortunately it cost $99. I have used it for years with excellent results and alsoft provides great support.

    My next recommendation would be to reinstall your OS 10.8.5 if Disk Warrior is not the path you select.
     
  3. JoeInMilwaukee macrumors member

    Joined:
    Apr 7, 2015
    Location:
    Milwaukee, WI
    #3
    I also highly recommend DiskWarrior. The $99 cost is well worth it!
     
  4. aidanpendragon, Apr 1, 2016
    Last edited: Apr 8, 2016

    aidanpendragon thread starter macrumors 6502a

    Joined:
    Jul 26, 2005
    #4
    Thanks...need to see if my DW is Universal or the old PPC version.
     
  5. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #5
  6. Fishrrman, Apr 2, 2016
    Last edited: Apr 2, 2016

    Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    OP wrote:
    "Machine still boots from the recovery partition or external HDD, and can see & back up data on the internal OS X partition, but can't boot from it or the Bootcamp partition."

    Seems to me if the SSD had "gone bad" on you, you wouldn't be able to boot ANYTHING (including the recovery partition).

    So... this indicates a software problem.
    May require re-installation of OS, maybe not.

    I would:
    1. Re-initialize the Mac partition
    2. Restore from backup

    I don't use BootCamp and would NEVER consider installing it onto a Mac on which I keep any critical information. Too much to go wrong.
    (Having said that, I -do- keep a copy of VMWare Fusion on my drive, but rarely use it).

    But if you absolutely have-to-have Windows running via BootCamp I guess you could:
    1. Reinstall BootCamp (after the regular OS rebuild above), and
    2. Restore from your Windows backup which you created with WinClone.
     
  7. aidanpendragon thread starter macrumors 6502a

    Joined:
    Jul 26, 2005
    #7
    So, I went to reinstall OS X, and got an error message that the drive wasn't formatted using the GUID Partition Table, so it couldn't install. Poking around in Disk Utility, it's formatted as Master Boot Record instead, and I can't change the partitioning type.

    That made me start to wonder if somehow the MBR had gone bad...after all, I can get the data but not boot. Some searching on MR suggests various cross-compatibility drivers by Paragon Software (NTFS for Mac and HFS+ for Windows) could be problematic. I recently got these free with a new backup HDD, and installed them. Perchance that's the issue. Any thoughts?
     
  8. dhcass macrumors newbie

    dhcass

    Joined:
    May 10, 2016
    Location:
    New York
    #8
     

Share This Page