2011 MacBook Pro External Screen Issues

Discussion in 'MacBook Pro' started by phib3r0ptik, Mar 18, 2011.

  1. phib3r0ptik, Mar 18, 2011
    Last edited: Mar 18, 2011

    phib3r0ptik macrumors newbie

    Joined:
    Jul 23, 2010
    #1
    I have been having some issues with my 2011 MacBook Pro with the HD 6750M graphics card, connected to an external 24" display via a DisplayPort to DVI adaptor. When I connect the screen it displays white 'static', then will every 10 seconds or so flick to displaying the image, then return to showing the static. Rebooting does not change anything. It has been working fine for around a week now, it started to occasionally flicker yesterday, today it will not work at all.
    Using a friends 2011 13" MacBook Pro works without any issues using the same screen and DVI adaptor. I do not have access to another screen with a DVI input currently, I will test when I can. However the fact that it works fine with my friends MBP suggests that it is not an issue with the screen.

    Anyone else had similar problems, or any ideas for a solution?

    http://www.youtube.com/watch?v=65vjOSuGt4E
     
  2. josh2007 macrumors member

    Joined:
    Dec 22, 2008
    #2
    I had the flicker AND overheating issue on my 2.2 quad into 24" cinema.
    The idle temp was getting up to 69c with screen attached.

    The flickering was terrible. I exchanged the 2.2 for a 13"i7, and traded the 24 for a new 27" with the leftover money.

    Now my idle temps with 27" attached are running 37c, and no flickering.

    My Mac guy tried a few 15's into the 24 and all had the same issues.
     
  3. KyleGP macrumors member

    Joined:
    May 3, 2011
    #3
    I'm having the same static issue with my MBP 15" 2011.

    Any light on this?
     
  4. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #4
    They just released an update yesterday. Check Software Updates.
     

Share This Page