2011 Macbook Pro power button / SMC issue

Discussion in 'MacBook Pro' started by stevenaaus, Mar 14, 2017.

  1. stevenaaus, Mar 14, 2017
    Last edited: Mar 14, 2017

    stevenaaus macrumors newbie

    Joined:
    Oct 23, 2013
    #1
    Hi.. I bought a late 2011 MB Pro with a marked/damaged keyboard cable. It also wouldnt power on from the power button, and would only turn on with battery removed and when connecting power supply. Otherwise, it runs great.

    So i installed the board (which looks very clean) into a spare bottom case, and the keyboard works
    fine, but i'll be d**d - the power button issue is the same.
    Additionally, touching the power pads to power on does not work either.

    Now this is where it gets weird. The EMC of the board doesn't correspond to a 13" late 2011 MB Pro. SMC: 1.68f99

    On the Apple page, https://support.apple.com/en-au/HT201518
    you can see the latest SMC is
    MacBook Pro (13-inch, Late 2011)
    MacBookPro8,1 MBP81.0047.2AB (2015-001) 1.68f98 (SMC 1.5)

    and my SMC 1.68f99 is only for the 15" and 17" models. Also, downloading the late 13" Pro SMC and unpacking it using xar... there does not appear to be any MB13 smcs at all.

    Maybe someone has some inside knowledge. I think this is a mismatched SMC issue.
    And Apple does not provide anyway to revert SMC of course. I have read there may be some crazy way to do it, ... I have already booted with rEFIt to try and do a SMC reset (to no avail) but getting the correct SMC file is a little scary.
     
  2. stevenaaus thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #2
    Hmmm. Ok. I managed to downgrade my emc to the correct version,
    but the power button behaviour has not changed.
    So maybe installing a battery will change something, but more likely not,
    and the problem is just a logic board issue/failure.

    Still - it's funny the Apple site for the 13" 2011 Pro SMC download does not contain a MB13 smc
     

Share This Page