2011 MacBook Pro with El Capitan showing very slow boot up

Discussion in 'OS X El Capitan (10.11)' started by munk18, Feb 21, 2016.

  1. munk18 macrumors newbie

    Joined:
    Jan 23, 2007
    #1
    Hello,
    I have an early 13" 2011 MacBook Pro. It had OS X Lion when purchasing.
    Two years later I upgraded it to OSX Mavericks.

    I recently did a CLEAN install of El Capitan. Wiped my HD and installed El Capitan.
    I did it with a bootable USB flash drive. The installation went fine. All through the years I did disk repair/verification, repair disk permissions when it was necessary. Before and after installation of El Capitan Disk Utility has shown repeatedly the hard drive is in healthy condition.

    Just last night I woke my computer up from sleep mode it seemed to be frozen.
    Some apps still running - Google Chrome, VLC.
    Mouse still worked. Any click from mouse or track pad would not effect anything on screen. Right click would work, but didn't help. I tried to shut down and gave me message that Chrome wasn't allowing it to do that.

    I pressed Command-Option-Esc to get to force quit and quit Chrome through there. Then I restarted and realized my troubles just started.

    It would boot back up, show apple logo with progress bar progressing to about 3/4 of a way and then hang on a blank grey screen for several minutes. I let it sit hoping something would change, but it just hung. Probably for at least 7 minutes.

    I then shut it down from power key because that was my only option. I disconnected ALL peripherals.
    Then I restarted holding down option key, same outcome - apple logo, slow progress bar and it hung around 1/2 of the way.
    I restarted holding down D key, same outcome.

    I reset NVRAM, but still same outcome.

    After all that I shut down and let it sit for a few minutes with everything unplugged. I restarted again and realized the progress bar WAS actually progressing just at an incredibly slow rate. So, I waited it out and it finally did come back to the login screen. Im talking 20 minutes plus.

    Once I finally got to the desktop - I did another disk check and it said everything was fine with my hard drive.

    I checked activity monitor and didn't show anything clogging up CPU or memory.

    I cleared out any login items (system preference>users and accounts>login items) that could be causing it.

    I would have checked disk permissions even though i doubt it would have helped, but it looks like El Capitan doesn't provide that feature in Disk Utility anymore?

    I then tried the same - restart + hold down D to see if i could run some sort of diagnostics, something! but it still just booted up to login, much faster this time (about 5-6 minutes which is waaay faster than 20 minutes, but still slow enough to worry).

    Logged back in and ran yet another first aid disk repair with same results.

    So, is there anyway to fix this? I admit the hardware is old, but for years I have NEVER had problems with booting up in OSX Lion or Mavericks and my gut is saying it software related. Or is this a product of bad CPU/MOBO? Anyway to check this? The only thing hardware related causing these problems i could think is my HD and it keeps telling me its in good condition.

    Reading around this forum it seems a 2011 MBP should be fine running El Capitan.

    Could it be faulty install? Can I reinstall El Capitan again while I already have it on my computer and would it help?

    Any input greatly appreciated.
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Check to make sure your hard drive is selected in the Startup Disk Preferences Pane.
    You could also try resetting the PRAM by cold booting while holding down the command-option-p-r key combination until you hear the start up chime a third time.

    Also try resetting the SMC: https://support.apple.com/en-ca/HT201295

    If you continue to have problems, open Console.app and see what error messages you are getting on boot up.
     
  3. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #3
    thanks for the reply.

    will do and will get back with my results.
    --- Post Merged, Feb 21, 2016 ---
    well I guess i got NVRAM and PRAM confused because that is what i did (command-option-p-r key) to reset.
    Nonetheless, I went into Startup Disk Preferences Pane and it had my disk there, but i actually selected it this time. Theres no click box, it just highlighed the disk image. I Restarted and eureka it booted up in seconds.

    Im still scratching my head over this one. I checked Console and really didnt see anything out of the ordinary. Anything specific I should be looking for in Console? Anyway, thanks again for the sound advice. Will keep thread up to date with my results.
     
  4. munk18, Feb 21, 2016
    Last edited: Feb 21, 2016

    munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #4
    So, i reinstalled Chrome. Deleted ALL login items, reset SMC and tried to restart again and it now is on this restart loop. For year Ive never experienced these problems and now regretting "upgrading" to El Capitan. I a lot of work to do and can't...

    It goes to the apple logo, progress bar and 50% of the way a bunch of code pops up on the screen over the existing apple logo/progress bar.
    Then a screen pops up saying "your computer restarted because of a problem, press any key or wait to continue".... etc in various languages.

    It did this about 5 times before I just shut down the computer by pressing the power button.

    Ill search around here for any solutions, but anyone have any tips??

    Ill try to restart in recovery mode, but Im concerned this constant restarting isn't helping the hardware at all.

    Edit - Attached at pic of the code on start up screen Im talking about
     

    Attached Files:

  5. Umbrarian macrumors member

    Joined:
    Oct 12, 2012
    Location:
    Texas
  6. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #6
    ok....?
     
  7. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #7
    It is having a kernel panic. This is usually caused by third party drivers. You probably have a driver that is incompatible with El Capitan.

    Disconnect all external peripherals and see if it will safe boot while holding down the shift key.

    Go in to USER & GROUPS and delete all log in items by highlighting each in turn and clicking on the minus symbol at the bottom of the window (Just unchecking the box is no sufficient).

    Then run software update and reboot.
     
  8. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #8
    Once I get back on desktop Ill do what you said to do, but I do remember I deleted everything in login items.

    I restarted holding down option-D and it said something along the lines "starting in Recovery from the internet this will take a while". Last time I checked holding down R or option-R would bring you into Recovery.

    I wanted to get to the Hardware Test. Its sitting on a circulating globe with a drop down to choose which Wi-fi to use. The only thing connected is AC plug. If it hangs on this screen ill try to reboot in safe mode in a bit.

    EDIT - OK, just now a warning exclamation point popped up on globe and below it lists
    apple.com/support
    -2002D

     
  9. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #9
    Try booting while holding down only D, (not option-d).
     
  10. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #10
    ok so far I tried holding down shift to boot in safe mode and was same screen with apple logo and kernal code etc... I tried it twice. I also tried holding down D and same outcome twice.

    I then restarted holding down command + R for OSX recovery and after a few minutes it got to OSX utilities/Recovery mode.
    I ran a disk repair and NOW its telling me I have something wrong with my hard drive. Literally, have never gotten this message in the past from the countless times Ive run a repair on any OS. Would installing a new OS cause this?

    Im back at the OSX Utilities screen in Recovery mode. I have the option to reinstall... worth it?
     
  11. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #11
    Was disk utility able to repair your hard drive? If not, it probably won't let you re-install the operating system.

    If disk utility was not able to repair your hard drive and you have a recent backup, you could erase and reformat the main partition as Apple Extended Format (Journalled), then re-install the operating system.
     
  12. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #12

    Well, yes and no... when i run repair on parent drive Hitachi HTS5450etc.. media it repairs, but the Macintosh HD, which is the main volume it has below on the Disk Utility sidebar, it wont repair. Now its saying its full capacity and wont mount in recovery mode.

    I really have no clue how installing a new OS or from a third party application could cause all this.

    I have back ups of my important files on an external, I did clean install of El Capitan, but I did just buy and install Logic Pro X on it. Thats pretty much the only important Program on the computer. It linked with my Apple ID so Ill be able to reinstall that app right?
     
  13. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #13
    "Now its saying its full capacity and wont mount in recovery mode."

    Sounds like the drive is completely full. That is always a problem.

    At this point, your best option is to use Disk Utility to reformat the main partition as Apple Extended Format (Journalled), then do the re-install and then add back in your data, being careful to leave at least 15% of the free.
     
  14. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #14
    I know its saying that, but it cant be full as I did a clean install less than a week ago. Just yesterday it said there was over 350GB on the hard drive. I would keep tabs on something like that all the time. and would keep about 200GB of space free on my main HD. Ill do another reformat and another clean re install, but how do I know I wont run into these same problems? I still have no clue whats wrong or causing it to act up...
     
  15. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #15
    It is possible that your drive is failing. The prudent thing to do might be to replace it.
     
  16. munk18 thread starter macrumors newbie

    Joined:
    Jan 23, 2007
    #16
    OK thanks for the help. The drive never showed any signs of failing when it was running Mavericks OS 10.9.5 or OS Lion for years.

    I dont know how now suddenly its failing from installing El Capitan. Once I figure out if its possible to reinstall previously purchased/installed programs from mac App store I will try to reinstall El Capitan and see how responsive it is from there.
     

Share This Page