2011 MBA USB Problem

Discussion in 'MacBook Air' started by luked14, Aug 20, 2011.

  1. luked14 macrumors 6502

    Joined:
    Aug 1, 2010
    #1
    I just purchased a 13" MBA i5 128 yesterday, and I just noticed an interesting problem with the USB port on the right side. I've tried several different USB devices and none of them will plug all the way into the port. I can only partially insert them and get the message about the USB drawing too much power. The left USB is working perfectly and reading all devices properly. Has anyone had or heard of this problem? Am I destined for a trip to the Genius Bar?
     
  2. ZBoater macrumors G3

    ZBoater

    Joined:
    Jul 2, 2007
    Location:
    Sunny Florida
    #2
    It seems that way. That doesn't sound like a user fixable problem.
     
  3. Yumunum macrumors 65816

    Yumunum

    Joined:
    Apr 24, 2011
    Location:
    U.S.
    #3
    I came on here cuz my left USB port doesn't work.

    Crap this sucks. I've already returned this once... I don't wanna make the drive back to my nearest Apple store.

    Anyone else have experience with this issue besides us?
     
  4. luked14 thread starter macrumors 6502

    Joined:
    Aug 1, 2010
    #4
    Just got back from the Apple store where they replaced mine because of the USB problem. Two of the pins were not in the correct place inside the port. I came out better this time since I got a Samsung SSD and display so I'm not complaining.
     
  5. Yumunum macrumors 65816

    Yumunum

    Joined:
    Apr 24, 2011
    Location:
    U.S.
    #5
    Something weird about my situation...

    Restarting the computer fixes the problem. Not sure why though

    Also, I've got the Samsung display + SSD two times in a row, and something tells me I won't be that lucky a third time :p
     
  6. luked14 thread starter macrumors 6502

    Joined:
    Aug 1, 2010
    #6
    Have you looked inside the port and compared to the other to see if they look the same?
     
  7. robby818 macrumors 6502a

    Joined:
    May 2, 2007
    #7
    Sometimes the ports are a little tight when new. I find that they do loosen up over time. I noticed that esp about the right port on one of my MBA's But it seems fine now after 2-3 weeks.
     
  8. NDN macrumors newbie

    Joined:
    Oct 13, 2011
    #8
    I also have a MBA 13" 2011 and my left USB port does not work sometimes, no matter which hardrive I am connecting. But after a reboot it works just fine ...
     

Share This Page