2011 MBP 13" displayport problem

Discussion in 'MacBook Pro' started by BitterMelon, Jan 12, 2012.

  1. BitterMelon macrumors newbie

    BitterMelon

    Joined:
    Feb 24, 2011
    #1
    At work we just bought two Samsung S27A950D screens. They allow both DisplayPort, HDMI and DVI connection. We also bought mini-DP -> DP cables. When conneting these to our 13" Macbook Pros (2.3 GHz), there is no picture on the display. Neither screen, neither cable, neither computer. The laptop screen does the blue blink once when connecting the cable (so something happens), but no picture on the Samsung and no screen detected in the Display settings.

    If I connect the screen via DVI and DVI -> mini-DP adapter, it all works perfectly. This, however, is a bit bulky, so I would prefer the smaller DP cable instead. At this point I gave up and just went with DVI.

    Strangely, however, I later noticed that when I connected a slightly older 15" MBP (2009, 2010?) it worked perfectly with the DP cable. What the...? :eek:

    What is going on here? Problem with Thunderbolt vs DisplayPort? Problem with the Sandy Bridge graphics? This is really getting on my nerves. :p

    Any help or insight would be appreciated.
     
  2. ChaosAngel macrumors member

    Joined:
    Sep 29, 2005
    Location:
    UK
    #2
    I have the same monitor and exactly the same issue with my Thunderbolt MacBook Air. As the OP stated, by older DP MacBook Air works fine.

    Any thoughts?
     
  3. NeilStrong macrumors newbie

    Joined:
    Jul 7, 2012
    #3
    Same problem with a Macbook Air 15" and Samsung S27A950D

    I've the same problem with my Mabook Air 2011 15" - The Samsung S27A950D doesn't work with either a Displayport cable OR a DVI adapter.....

    Anyone made any progress on this ... is it the Samsung or the Mac? :mad:

    Cheers
    Neil
     
  4. NeilStrong macrumors newbie

    Joined:
    Jul 7, 2012
    #4
    Samsung S27A950D DisplayPort Update

    Just tried the same monitor on my 24" iMac 2009 and although it works fine with a DVI adapter, it still doesn't work with DisplayPort cable ..... just get a flickering blue screen with two differently shaded horizontal blue bands, although the Mac definitely detects something when I plug it in.

    I still can't eliminate the cable, the monitor or an OSX DisplayPort problem at this point.
    :confused:
     
  5. LaunchpadBS macrumors 6502a

    Joined:
    Nov 11, 2008
    Location:
    iLondon/iDurban
    #5
    I've got a Mini DP -> DP setup with an HP ZR2440w and my 13" 2012 MBP with no picture problems...
     

Share This Page