2011 MBP clamshell auto-brightness

Discussion in 'MacBook Pro' started by ulbador, May 13, 2011.

  1. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #1
    The auto brightness "feature" on my new MacBook Pro is driving me nuts. I'm running in clamshell mode, hooked to an external monitor, and every time I visit a dark webpage, hide things with expose, etc, the whole screen dims noticeably. I thought maybe I was having a stroke or something.

    I'm not seeing any obvious way in the Display settings to turn it off. Anybody have any ideas?

    Thanks!
     
  2. OS X Dude macrumors 6502a

    OS X Dude

    Joined:
    Jun 30, 2007
    Location:
    UK
    #2
    System Preferences>Displays>Untick the box "Automatically adjust brightness as ambient light changes".

    It did my head in as well. I love it on my phone but not on my MBP for some reason.
     
  3. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #3
    It drove me mad too, so I disabled it very quickly. If you have it turned on, and you move your head 2 inches, the brightness changes because the level of ambient light, as detected by the MacBook Pro's sensor, has changed!
    It's ridiculous.
     
  4. mape2k macrumors regular

    Joined:
    Apr 18, 2011
    Location:
    Germany
  5. OS X Dude macrumors 6502a

    OS X Dude

    Joined:
    Jun 30, 2007
    Location:
    UK
    #5
    It's on the top by the FaceTime/iSight camera.

    TS, did you get your problem solved?
     
  6. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #6
    If you're running in clamshell mode why does it change? The internal screen in clamshell mode is turned off and the macbook pro cannot change the brightness of an external screen.
     
  7. ulbador, May 13, 2011
    Last edited: May 13, 2011

    ulbador thread starter macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #7
    Hence my problem. No such option on the Display screen (presumably because it is in clamshell mode). I really wish I could capture it with my iPhone on video, because the behavior is amazingly odd. The difference isn't dramatic, but it's enough to make you wonder "did the sun just go behind the clouds outside?"

    Edit:

    As an addendum, it only seems to happen when in clamshell mode. It even happens when it's in straight mirror or span mode though. Makes me wonder if it's the monitor. Gonna try to reboot in Bootcamp and see what happens.

    Final Edit:

    I figured out what it was. I have this monitor:

    http://www.amazon.com/Viewsonic-VX2...BJ7S/ref=sr_1_1?ie=UTF8&qid=1305320481&sr=8-1

    It was the damned "Dynamic Contrast" option on the monitor itself.
     

Share This Page