2011 MBP Ethernet Port not showing up (Sierra)

Discussion in 'MacBook Pro' started by beedoola, Nov 5, 2017.

  1. beedoola macrumors member

    Joined:
    Jun 18, 2012
    #1
    My ethernet port has not been working. To the advice of some threads I read on the internet I deleted the Ethernet from my network preferences and rebooted my computer. This unfortunately did not cause the port to reappear and when I try to click the "+" to add a device the Ethernet port is not shown.

    How can I get it back? Running Sierra 10.12.6.
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Do you see anything regarding ethernet at About This Mac (System Information)>System Report>Network?
     
  3. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    Good advice in the post above this one.

    If you DO NOT see anything regarding ethernet, it could be either a hardware or -software- failure.

    I believe certain files/drivers in the OS are loaded at boot time that will "recognize" the presence of the ethernet port, and make it active. If those drivers don't load -- no ethernet because the OS doesn't "see the port" is there.

    Then again, it could be a hardware failure.

    You should also try the "SMC reset" PRAM reset (or equivalent), etc.
     
  4. beedoola thread starter macrumors member

    Joined:
    Jun 18, 2012
    #4
    Thanks for the info. I did check the System report. The Ethernet card was showing in my Network preferences before I deleted it, as was info in the System Report. After delating the Ethernet port from my Network preferences and restarting the computer the Ethernet port no longer showed up in the Network preferences and in the System Report. In the latter all you see is this under the Ethernet card info:

    "This computer does not appear to have any PCI Ethernet cards installed."

    I had read there was an Apple update that messed people's ethernet cards and caused them not to be recognized. Someone suggested getting an uncorrupted/updated file from another working OSX system and then adding that to the system/library/extensions. I did this but that didn't seem to help. Though my friend isn't very computer savvy and she could not confirm the last time she used her Ethernet port, so perhaps she could have the same software issue.
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    OP:

    At this point, I'd boot from the recovery partition, and do a re-install of the OS.

    It's not hard (though it takes some time), and won't delete any of your files or data.

    This should restore any missing files or drivers. If the ethernet STILL doesn't work afterwards, it's probably a "hardware problem".

    Give that a try, run System Information again, and get back to us.
     
  6. beedoola thread starter macrumors member

    Joined:
    Jun 18, 2012
    #6
    Is there a guide to doing this? I changed out the original drive for an SSD, cloning the other drive. This was awhile ago and had no issue with the ethernet port.
     
  7. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    1. Boot to the recovery partition
    2. Choose option to re-install OS.

    Do you have a brick-n-mortar Apple store anywhere near?
    Have you tried taking it there?

    Another approach:
    Buy an EXTERNAL USB ethernet adapter, and use that.
    I believe these use additional drivers that you install.
    Clunky? Yes. But... what works.... works.
     

Share This Page

6 November 5, 2017