2011 mbp not going to sleep right away when lid closed

Discussion in 'MacBook Pro' started by i hate phones, Apr 11, 2011.

  1. i hate phones macrumors 6502a

    Joined:
    Jul 5, 2010
    Location:
    Philly Suburbs, PA
    #1
    I tried searching but couldn't find anything recent...

    When I close my mbp it used to go right to sleep, now it stays on and takes almost a minute before going to sleep. Any ideas what changed this or what settings I can look into? I don't know what other info to provide in order to get some help, the only thing I recently installed was better snap tool. When I get home from work I'll try disabling that to see if that works, didn't think about that last night...

    thanks!
     
  2. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #2
    How old was your old MBP? How much RAM did you have on it? How much RAM do you have on the new MBP?
     
  3. i hate phones thread starter macrumors 6502a

    Joined:
    Jul 5, 2010
    Location:
    Philly Suburbs, PA
    #3
    this is my first mbp, its the standard 17" so 4gb ram
     
  4. Krevnik macrumors 68040

    Krevnik

    Joined:
    Sep 8, 2003
    #4
    When you put the machine to sleep, it is also dumping out the RAM to disk. this can become slower as time goes on. Also, anything trying to work when the machine goes to sleep can delay it. Sounds like you might already have found the source. Did it fix it?
     
  5. teddat macrumors member

    teddat

    Joined:
    Apr 8, 2011
    #5
    Sleep does not require ram to be copied to HD. since the computer doesn't power down completely, it still supplies a tiny bit of power to ram so it holds it contents. This why its nearly instant on when you awake from sleep. It is only hibernation that moves ram data to non volatile storage. unless apple is using a different kind of sleep.
     
  6. Final Hour macrumors newbie

    Joined:
    Oct 31, 2010
    Location:
    Israel
    #6
    OP-

    I've read a few threads of this occuring, the one common denominator with all of them was that in each case users were trying to print to a wireless printer, the print job failed and sticks around in your print queue. If you check and clear that Q you should be good to go.

    I can't remember if this applies to wired printers, and this could be completely unrelated to your issue, but hey, it's worth a shot!
     
  7. Krevnik macrumors 68040

    Krevnik

    Joined:
    Sep 8, 2003
    #7
    They are. Apple enabled "SafeSleep" awhile back in their laptops (laptops released in the 10.4 timeframe). When it goes to sleep, it writes a copy of RAM out to disk, exactly as if you are hibernating.

    The idea is that if your battery dies while it is asleep you don't lose your work. When waking up, it ignores the sleep image (/var/vm/sleepimage) because it isn't needed. The kernel only uses it on boot.

    Really is a better solution than hibernation, IMO, and yes, it has saved my butt a couple times. :)
     
  8. teddat macrumors member

    teddat

    Joined:
    Apr 8, 2011
    #8
    Excellent info. i learned something new today. thanks!
     
  9. i hate phones thread starter macrumors 6502a

    Joined:
    Jul 5, 2010
    Location:
    Philly Suburbs, PA
    #9
    thank you so much!! that seems to have been the exact problem. didn't even know i had anything in my print queue! goes right to sleep now, thanks!
     
  10. lord patton macrumors 65816

    lord patton

    Joined:
    Jun 6, 2005
    Location:
    Chicago
    #10
    Just to add, I had (have?) the same issue, and deleting and old print queue fixed it (I think)
     

Share This Page