2011 MBP Power Supply issue?

zenit

macrumors member
Original poster
Sep 2, 2010
50
0
Recently my MBP developed a weird, very intermittent issue. When i plug in the power cord into the laptop, the green light illuminates very dim instead of usual bright green, and the laptop shows that it is plugged in but not charging. It usually starts charging after i plug it in and out a few times.

Is this a known issue or my power supply or motherboard going bad?'

I already cleaned the contacts, so it is probably not dirt clogging up the connector.

I am a bit apprehensive about taking it to Apple, because it is such an intermittent but annoying problem which is rather difficult to replicate.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,419
758
Recently my MBP developed a weird, very intermittent issue. When i plug in the power cord into the laptop, the green light illuminates very dim instead of usual bright green, and the laptop shows that it is plugged in but not charging. It usually starts charging after i plug it in and out a few times.

Is this a known issue or my power supply or motherboard going bad?'

I already cleaned the contacts, so it is probably not dirt clogging up the connector.

I am a bit apprehensive about taking it to Apple, because it is such an intermittent but annoying problem which is rather difficult to replicate.
It's normal that it may not charge immediately when plugged in. Also, if your battery is already charged at 93% or higher, it's normal that it won't charge. Read the CHARGING section of the following link, including the link for troubleshooting MagSafe adapters. This should answer most, if not all, of your battery questions:
 

zenit

macrumors member
Original poster
Sep 2, 2010
50
0
It's normal that it may not charge immediately when plugged in. Also, if your battery is already charged at 93% or higher, it's normal that it won't charge. Read the CHARGING section of the following link, including the link for troubleshooting MagSafe adapters. This should answer most, if not all, of your battery questions:
the issue is that the battery was way below 50% when I try to charge it, and even after waiting for 10+ minutes the light never went bright green or orange (like when it is charging).

It also was not functioning correctly when plugged into power supply. The computer reported the power plugged in, but the battery was still discharging instead of computer being powered by the power supply.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,419
758
the issue is that the battery was way below 50% when I try to charge it, and even after waiting for 10+ minutes the light never went bright green or orange (like when it is charging).

It also was not functioning correctly when plugged into power supply. The computer reported the power plugged in, but the battery was still discharging instead of computer being powered by the power supply.
Did you troubleshoot the adapter, as recommended? You may also try resetting the SMC.
 

thundersteele

macrumors 68030
Oct 19, 2011
2,984
7
Switzerland
I am a bit apprehensive about taking it to Apple, because it is such an intermittent but annoying problem which is rather difficult to replicate.
Usually they are very understanding and try to fix your problem. I don't think it's necessary that you can reproduce it in the store. If GGJs troubleshooting advices don't help, just take it in and have them check it.