2011 MBP SSD Formatting Woes

Discussion in 'Mac Basics and Help' started by Elven, Oct 17, 2016.

  1. Elven macrumors 6502a

    Elven

    Joined:
    May 13, 2008
    Location:
    UK
    #1
    Just put a new SSD into my girlfriends MBP since it was showing classic signs of HD failure. When attempting to format as GUID it will fail almost immediately with the error;

    "erase process has failed, click done to continue"

    Disk utilities in Internet Recovery mode also shows the SSD, details it's specifications exactly, yet won't let me wipe the sodding thing? what gives?
     
  2. Elven thread starter macrumors 6502a

    Elven

    Joined:
    May 13, 2008
    Location:
    UK
    #2
    All sorted, no idea why but suddenly it let me format to GUID. Installing Sierra now.
     
  3. glenthompson macrumors 68000

    glenthompson

    Joined:
    Apr 27, 2011
    Location:
    Virginia
    #3
    It may be a flakey sata cable. Common on that vintage. Cheap, easy fix.
     
  4. Elven thread starter macrumors 6502a

    Elven

    Joined:
    May 13, 2008
    Location:
    UK
    #4
    How would I know which is the correct cable to get?
     
  5. JamesPDX Suspended

    JamesPDX

    Joined:
    Aug 26, 2014
    Location:
    USA
  6. Elven thread starter macrumors 6502a

    Elven

    Joined:
    May 13, 2008
    Location:
    UK
    #6
    I figured it out 2010 Macbook and got the MB number, ordered a few cables on Ebay, and digging out my iFixit kit for my iMac.

    Thanks though, good to be able to get support so fast!
     

Share This Page