2011 MBP "X" over battery, what logic board part causes this?

Discussion in 'MacBook Pro' started by Nasty275ss, Apr 22, 2014.

  1. Nasty275ss macrumors member

    Joined:
    Mar 19, 2014
    #1
    Ive gotta 13" 2011 MBP and battery icon has the X over it and computer only works when plugged into magsafe. Ive been reading alllllll over and not seeing to much on what part to test on logic board and what controls the battery being charged, the battery is fine, charges in other computers, and Im very positive its not a simple magsafe fix or new battery like you hear a lot, I have the multimeter out but I really dont know what part controls the battery and what volts to look for, If anyone can help I would really appreciate any feedback. Thanks
     
  2. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #2
  3. Nasty275ss thread starter macrumors member

    Joined:
    Mar 19, 2014
    #3
    Did all the SMC and PRAM resets and nothing, Ive never had luck with SMC, but the mac works fine otherwise, and the battery is showing up as "Not Installed" when its plugged in, magsafe always stays green. Im just trying to figure out what parts on logic board I can test, Ive found some info on what parts to test but it was for a 2009 MBP and the board looked very different to a 2011, I had a 2010 with this same problem a couple weeks ago, ended up selling it, but this has to be a simple solder fix on the board (I'm hoping) because there are plenty of places that fix these and Id like to know thier secret, lol.
     
  4. Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #4
    I'm not 100% sure but I think that the charging circuit is part of the battery itself, not the logic board.
     
  5. Nasty275ss thread starter macrumors member

    Joined:
    Mar 19, 2014
    #5
    oh really? thatd be interesting, that's weird that it would work in other Mac books though, I just know that all those little parts on the board one of them has to be responsible for it not charging and I know it would be an easy fix if I know what the hell to look for I'm kind of new to repairing MacBooks and I'm trying to learn as much as I can I really enjoy doing this stuff and I want to do it right, but theres probably alot of parts that go into charging the battery but im just a newb n dunno what to test.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    The battery is a part of the charging circuit, in the sense that a battery won't charge if it is not detected.

    You said that this battery worked in another MBPro - Did you try a different battery in THIS MBPro?

    Check the internal battery connector for damage or corrosion.

    If your battery is actually fully charged, what happens when you press the battery status button on the left edge of your MBPro?
    Do you get all the lights, steady? Or, do you get a flashing pattern, or blinking LEDs ?
     
  7. Nasty275ss thread starter macrumors member

    Joined:
    Mar 19, 2014
    #7
    I have tried 3 different batteries in the MacBook and none of them charge and I know for a fact the batteries are good so it's obviously a logic board issue at least that is what I thinkI'm on the road right now I will try that when I get home to put a fully charged battery in itI can't remember if the lights on the side come on or not I'm pretty sure that they didn't come on at all but I will check when I get home

    ----------

    also I cleaned the entire board with alcohol and a magnifying glass to check areas that may have looks suspicious but everything looks good my guess is that there is one simple little fuse or something that must be blown I am not aware of any water damage to the board but the previous owner may have spilled something on it I'm not sure
     
  8. Nasty275ss thread starter macrumors member

    Joined:
    Mar 19, 2014
    #8
    also I don't know if this is a sign of something but with the battery installed or not installed and the computer off as soon as I plug in the charger the computer turns on by itself and the magsafe stays green
     
  9. Nasty275ss thread starter macrumors member

    Joined:
    Mar 19, 2014
    #9
    ok, I have no lights on the indicator on the side. and also when you unplug the mac it stays running but display goes black instantly and is non responsive when you try to wake it up (spacebar) but when you plug the magsafe back in, it works fine but still doesnt charge the battery and doesnt even recognize one being installed.
     

Share This Page