2012 13" MacBook Air dropping wireless

zObsidian

macrumors member
Original poster
Nov 25, 2010
53
0
Hi there,

I just received my 2012 13" MacBook Air preloaded with Mountain Lion, it's great but it seems as if I keep dropping my wireless connection, sometimes once in 5 minutes, sometimes once an hour.

I'm using a Linksys WRT610N dual-band router running DD-WRT. I have an iPad, another laptop and a desktop that are all wireless and they seem to retain a signal just fine. In fact, the Air is generally in the same room as the router.

The Air will always show full wireless bars but then lose signal. Sometimes it will take a few seconds for it to re-establish a connection, sometimes I have to manually do it with Safari's network diagnostics where it will instantly find and pick up the signal.

I used iStumbler to scan nearby wireless connections to check for interference, my neighbours are mostly on G, channel 6. My router is set for channel 8 on G-band and channel 40 on the N-band (the only N-band around). Both bands keep dropping.

Anyone else having problems? Suggestions on anything else I can try to fix or diagnose the problem? I'm hoping this is something software related (ML?) and not a hardware problem.

Thanks.
 
Last edited:

seared.ahi

macrumors regular
Aug 5, 2012
135
0
Same problem. I go through Network Diagnostics in Safari like you too. But it always comes back fast and all the lights go green - I've never actually had to reset my router to fix it like I used to have to with my Powerbook - which got "Connection Timeouts" (which is actually a router problem - I know because ALL my Macs/iPhones would go out at the same time). Fortunately no connection timeouts on my new MBA, just a "!" in the wifi spot.

This problem happens most often after I wake up my computer from sleep. But it does't happen a lot. Maybe 2-3 times a day? And I've only had my MBA for 3 days. Haaha.
 

zObsidian

macrumors member
Original poster
Nov 25, 2010
53
0
I actually don't get the "!", just a gray wifi icon.

What's puzzling is that I have a cheapo Acer netbook on G-wifi sitting next to the Air happily connected to the internet without problems. Insert sadface: :(
 

ixodes

macrumors 601
Jan 11, 2012
4,430
2
Pacific Coast, USA
I work with a very large contingent of Mac enthusiasts. I'm guessing there's at least 20 of us that have 13" 2012 MBA's.

Recently I read about this issue but have not experienced it with mine.

Out of curiosity I asked around at work and none of us have been affected. Perhaps this is a problem that only affects a few machines.
 

seared.ahi

macrumors regular
Aug 5, 2012
135
0
I work with a very large contingent of Mac enthusiasts. I'm guessing there's at least 20 of us that have 13" 2012 MBA's.

Recently I read about this issue but have not experienced it with mine.

Out of curiosity I asked around at work and none of us have been affected. Perhaps this is a problem that only affects a few machines.
I think it'd be more a software issue than anything.
 

ixodes

macrumors 601
Jan 11, 2012
4,430
2
Pacific Coast, USA
I think it'd be more a software issue than anything.
It's hard to say, yet I tend to agree with you. If it were mine, I'd take the time, wipe the drive and do a complete clean install. I never hesitate to take this approach whenever I encounter a major slowdown or other odd or intermittent issue.

You'd be surprised how effective it is.
 

zObsidian

macrumors member
Original poster
Nov 25, 2010
53
0
How many of you are running Mountain Lion? Perhaps it's a software issue with the new OS.
 

seared.ahi

macrumors regular
Aug 5, 2012
135
0
It's hard to say, yet I tend to agree with you. If it were mine, I'd take the time, wipe the drive and do a complete clean install. I never hesitate to take this approach whenever I encounter a major slowdown or other odd or intermittent issue.

You'd be surprised how effective it is.
Sort of an extreme solution. It's not that bad and I haven't encountered the problem at all today.

How many of you are running Mountain Lion? Perhaps it's a software issue with the new OS.
Mountain Lion came pre-installed on mine just like yours.
 

fireos

macrumors newbie
Aug 10, 2012
7
0
aiirrr

My macbook air (august 2012) wireless connection is running smoothly. I didn't upgrade yet on the new os.