2012 13" MBA - Comma & Period Keys Nonfunctional

Discussion in 'MacBook Air' started by MacDann, Apr 24, 2017.

  1. MacDann macrumors 6502a

    MacDann

    Joined:
    Mar 27, 2007
    Location:
    Can see the end of the Earth from here
    #1
    I have a 2012 13" MBA that I am running the Sierra public betas on. After a recent update, my comma and period keys no longer work. I'm not sure if this is a result of the software updates or a hardware issue. Every other key works as expected, and there have been no physical changes or events such as spillage or drops to the MBA.

    I find it odd that these two keys would suddenly stop working of their own accord.

    Searches of the bug reports for Sierra public betas yield no issues of this type that I could find.

    Any ideas/direction to try and resolve this would be appreciated.

    MacDann
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
  3. MacDann thread starter macrumors 6502a

    MacDann

    Joined:
    Mar 27, 2007
    Location:
    Can see the end of the Earth from here
    #3
    Dang! You know, I feel stupid saying this now, but no, I have not.

    It's been so long since I've had an issue of any kind with my Macs I forgot the cardinal rules of troubleshooting.

    Thank you! I'll report back later today when I get a chance to do this.

    MacDann
     
  4. MacDann thread starter macrumors 6502a

    MacDann

    Joined:
    Mar 27, 2007
    Location:
    Can see the end of the Earth from here
    #4
    Zapped the PRAM and did an SMC reset - no joy
     
  5. ryguy92000 macrumors regular

    ryguy92000

    Joined:
    Sep 20, 2014
    Location:
    Salt Lake City, UT
    #5
    roll back the beta. you likely have a bad kext.
     
  6. MacDann thread starter macrumors 6502a

    MacDann

    Joined:
    Mar 27, 2007
    Location:
    Can see the end of the Earth from here
    #6
    Thanks! That's next.

    Surprisingly, when I first reset the PRAM and SMC, it worked. Then I let it update (bad idea) and now it doesn't. And that's after another PRAM and SMC reset.

    Fortunately, I don't use this machine for much so I can easily restore it and revert back to a stable OS. I'll do that tonight and report back.

    MacDann
     
  7. MacDann thread starter macrumors 6502a

    MacDann

    Joined:
    Mar 27, 2007
    Location:
    Can see the end of the Earth from here
    #7
    Well, I got around to installing a production version of Sierra on the machine today. No joy. Still no comma or period.

    Any other ideas/suggestions?

    MacDann
     

Share This Page