2012 Air, WiFi goes weird

quackers82

macrumors 6502
Original poster
Mar 13, 2014
340
168
Anybody else with a 2012 Air have the WiFi stop working almost or grind to a VERY slow speed when browsing the internet? When i ping the router to see if its LAN or WAN side the ping rates are very high. Rebooting the Mac seems to make it go back to normal for a while. My Macbook Pro running 10.9 on the same WiFi Access point right next to it will load everything instantly without issue, and the Air ran without issue on 10.8 so I'm convinced 10.10 is the problem.
 

xanadeath

macrumors 6502
Jul 31, 2008
425
25
California
Anybody else with a 2012 Air have the WiFi stop working almost or grind to a VERY slow speed when browsing the internet? When i ping the router to see if its LAN or WAN side the ping rates are very high. Rebooting the Mac seems to make it go back to normal for a while. My Macbook Pro running 10.9 on the same WiFi Access point right next to it will load everything instantly without issue, and the Air ran without issue on 10.8 so I'm convinced 10.10 is the problem.
There's a thread already going on about this, but the thread is titled MBP specific. A lot of people seem to be experiencing problems though, myself included. Like you, my internet grinds to a halt/very slow speed, but the wifi does not actually disconnect. This happens intermittently.

Macrumors thread: http://forums.macrumors.com/showthread.php?t=1802327
Apple Discussions thread:https://discussions.apple.com/thread/6601963?start=0&tstart=0
 

sosull

macrumors member
Aug 3, 2014
33
0
Anybody else with a 2012 Air have the WiFi stop working almost or grind to a VERY slow speed when browsing the internet? When i ping the router to see if its LAN or WAN side the ping rates are very high. Rebooting the Mac seems to make it go back to normal for a while. My Macbook Pro running 10.9 on the same WiFi Access point right next to it will load everything instantly without issue, and the Air ran without issue on 10.8 so I'm convinced 10.10 is the problem.
Under System Preferences, select Network. Create a new location, and in the gear icon at the bottom of the service list, use Set Service Order to rearrange the Network Services so that WiFi is above Bluetooth DUN, Bluetooth PAN, and Thunderbolt.

If that doesn't work, try turning off Bluetooth and any Power Nap/Wake for Network Access/Wake for Bluetooth settings.