2012 iMac - Slow WIFI

Discussion in 'iMac' started by platypus63, Mar 25, 2013.

  1. platypus63 macrumors regular

    Joined:
    Feb 28, 2006
    Location:
    Zanzibar Land
    #1
    Hey everyone,

    I Just got the late 2012 27"iMac this weekend, and everything is great except for the wifi speed...

    I have FIOS with 15 mbps download, and every computer I've tested (at the same distance from router) has achieved 13-15mbps speeds, this includes 13"mbp, 24"iMac, dell laptop, iphone, ipad.

    New 27"iMac gets speeds from 3-5mbps through the same connection... I've tried resetting the router, zapping PRAM, resetting SMC, still the same...

    Anyone else with this problem? Any ideas on fix?

    I've tested speed with speedtest.net and speedtest.verzion.net btw

    Thanks!
     
  2. Malacoda macrumors member

    Joined:
    Mar 19, 2009
    Location:
    Meridian, ID
    #2
    I don't have any solution for you, but I thought I'd offer you a data point.

    I bought a new 27" iMac a few weeks ago, and it's speed on my WiFi network was very low when I connected straight to my DSL modem/router with built-in WiFi. It's actually a nice unit, dual-channel and gigabit ethernet. All my other machines (older 24" iMac, 15" MacBook Pro, iPhone, iPad) woud connect to it and appropriate speeds.

    I also have a Time Capsule plugged into the modem, acting as a second WiFI spot. When I switched the iMac to the Time Capsule, it achieved normal speeds.

    Not sure what the issue was, but I also recently had ethernet ran to my home office, so WiFi of any kind is not an issue.
     
  3. shaee macrumors newbie

    Joined:
    Jul 6, 2010
  4. platypus63 thread starter macrumors regular

    Joined:
    Feb 28, 2006
    Location:
    Zanzibar Land
    #4
    Thanks for the tip.

    I tried all 11 channels... Channel 9 worked the best for the iMac, with 10mbps on the iMac out of 15 possible.

    Interestingly, while 9 was fastest for iMac, every other device in the house (tiny apartment) which were getting 15mbps with other channels now is down to 10mbps on channel 9.

    I wonder why this new iMac is so wifi sensitive.
     
  5. AllergyDoc macrumors 65816

    AllergyDoc

    Joined:
    Mar 17, 2013
    Location:
    Utah, USA
    #5
    Funny, I just went through this with my new 27" iMac. I had to update the router software and set the channel to 8, which worked like a charm. I get 23+ Mbps download on service sold as 20, on all my devices. Oh, I also had to set my router to ASE only, which forced it to use the higher capabilities. I have a Netgear middle of the road router.
     

Share This Page