Resolved 2012 Mac Mini runaway log problem - help needed

Discussion in 'Mac mini' started by dotme, Feb 19, 2019.

  1. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #1
    I'm not experienced when it comes to troubleshooting and would be very grateful for some help. Long read, but hopefully the detail will help.

    Late-2012 Mac Mini, 500GB HD with 300GB free, and Crucial 16GB RAM. The only attached peripherals are a wired Apple keyboard, and dual monitors.

    Perfectly happy little machine until last week, when we upgraded from 10.14.2 to 10.14.3

    After the upgrade, it was unusable - 40 seconds or more between clicking an icon and anything happening. Same behavior whether logged in as main user, or guest. Really sluggish. Safe mode worked fine though.

    Unable to find a cause, we used time machine to restore to the day before the upgrade, so we put it back on 10.14.2, and left it overnight.

    In the morning I found that it was now out of disk space! (It had eaten all 300GB of free space, leaving a paltry 11MB remaining, which it continued to try and eat). Unable to do anything with it at that point, I re-ran the Time Machine restore again, and this time logged in as soon as it was done.

    In 5 minutes after booting up, there were over 4GB of disk writes according to Activity Monitor - it is eating space again. Turned off iCloud, unchecked all Spotlight indexes. No change.

    When I sort Activity Monitor by disk writes, nothing in the list comes anywhere close to 4GB written since restart. So whatever's eating disk space isn't visible to me as a process.

    You can hear the drive working all the time. In Console, I identified a log that is out of control. The log at

    /var/log/DisgnosticMessages is writing several lines per second. So I think I found the culprit. It's a file called "2019.2.18.asl" and most of the entries are under a process called "ReportCrash"

    By repeatedly clicking to clear the log, I seem to be able to contain the HDD growth, but if I don't do that, I'm going to run out of disk space again.

    In the course of troubleshooting, I have run Repair Disk on the HDD from Recovery Mode (No errors found) and I have swapped the several-years-old Crucial 16GB Ram with the original 4GB. Also performed the PRAM/SMC reset.

    No improvement.

    If you made it this far, thank you. I'd welcome any advice as to my next move - I'm not well versed with the inner workings so not sure what to try next. It sees light use as a web browser mostly, so the only 3rd party software I think it's running would be Adobe's PDF reader.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Have you considered "going back" to 10.14.2?

    If "option a" works, and "option b" does not work, which is the obvious choice?
     
  3. dotme thread starter macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #3
    It was the move back to 10.14.2 that started the disk space crisis, unfortunately.
     
  4. gcbarre macrumors newbie

    gcbarre

    Joined:
    Jan 15, 2014
    #4
    I also have a problem the time I open an encrypted DMG file or I work with Photos, everything gets too slow, the Beach Ball does not go away, soon all the remaining hard disk space is gone. I can force shut down the Mini and it boots fine and I avoid using my big photo files.

    I have not been able to backup in Time Machine, I have different external HDs.

    I have an internal SSD that was Fusion with the original 1TB HD but since Mojave I had to split them again, using the SSD for Mojave and the 1 TB for Boot camp, as I was not using Windows 10 I reinstalled High Sierra in it and everything works perfectly fine.

    My son auto boots in Mojave and I Alt Boot to High Sierra.
     
  5. rmdeluca macrumors regular

    Joined:
    Oct 30, 2018
    #5
    This sounds like a daemon run amok. It’s crashing and being restarted repeatedly, generating a crash log every time. Is there any other info in the crash log about what service/daemon is crashing?

    Another thing you can do to find it is sort activity monitor by CPU usage and see if one processs keeps appearing and disappearing over and over again. A big clue will be its PID (process ID) will keep incrementing every time it is restarted.

    Once you find it, rename it to something else so it can’t be restarted again. Then you’ll have time to figure out the real problem without your disk getting beat up.
     
  6. dotme thread starter macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #6
    Resolved.

    Posting a follow up in case someone else runs into the same issue. One of the 8GB Crucial modules failed the hardware test when I tested each individually with an empty second slot.

    Replacing with the 4GB original RAM as I tried above did not stop the runaway log, but when I did a full restore from Time Machine with the replacement RAM already in place, it did. So the bad RAM caused the drive activity, and it was a combination of replacing the RAM, plus a full restore, that ended up resolving the problem of drive writes that didn't show as a process in Activity Monitor and rapidly filled up the drive.

    New RAM ordered. My thanks to those who replied to my original post.
     

Share This Page