2012 MacBook Pro keeps crashing - fresh install of ML

Discussion in 'MacBook Pro' started by circa7, Jan 21, 2013.

  1. circa7 macrumors regular

    Joined:
    Jan 8, 2013
    #1
    This has happened twice in the past few days. The computer crashes and has a gray screen with an error message. Can anyone help? Here is my error log:

    Interval Since Last Panic Report: 7846 sec
    Panics Since Last Report: 1
    Anonymous UUID: 190B7E53-8C46-4FD8-3D50-2FE0FA6139F5

    Mon Jan 21 09:28:46 2013
    panic(cpu 0 caller 0xffffff8025043d8e): "a freed zone element has been modified in zone: kalloc.32"@/SourceCache/xnu/xnu-2050.20.9/osfmk/kern/zalloc.c:219
    Backtrace (CPU 0), Frame : Return Address
    0xffffff81166bba90 : 0xffffff802501d626
    0xffffff81166bbb00 : 0xffffff8025043d8e
    0xffffff81166bbb40 : 0xffffff80250435d2
    0xffffff81166bbc20 : 0xffffff80250245ed
    0xffffff81166bbc50 : 0xffffff80253ecf9d
    0xffffff81166bbc80 : 0xffffff8025402797
    0xffffff81166bbcb0 : 0xffffff8025400c93
    0xffffff81166bbd00 : 0xffffff80253ff162
    0xffffff81166bbd60 : 0xffffff80253f0e81
    0xffffff81166bbda0 : 0xffffff80253f0e81
    0xffffff81166bbde0 : 0xffffff8025426c23
    0xffffff81166bbe00 : 0xffffff80254311e1
    0xffffff81166bbe10 : 0xffffff8025462f68
    0xffffff81166bbe50 : 0xffffff8025094212
    0xffffff81166bbe80 : 0xffffff8025020aed
    0xffffff81166bbeb0 : 0xffffff8025010448
    0xffffff81166bbf00 : 0xffffff802501961b
    0xffffff81166bbf70 : 0xffffff80250a5db6
    0xffffff81166bbfb0 : 0xffffff80250cdc23

    BSD process name corresponding to current thread: activitymonitord

    Mac OS version:
    12C3012

    Kernel version:
    Darwin Kernel Version 12.2.1: Thu Oct 18 16:32:48 PDT 2012; root:xnu-2050.20.9~2/RELEASE_X86_64
    Kernel UUID: 0AFA55FD-872F-3BBE-8630-214EB586A16D
    Kernel slide: 0x0000000024e00000
    Kernel text base: 0xffffff8025000000
    System model name: MacBookPro9,1 (Mac-4B7AC7E43945597E)

    System uptime in nanoseconds: 5404773673114
    last loaded kext at 4040451219392: com.apple.driver.AppleBluetoothMultitouch 75.19 (addr 0xffffff7fa74a1000, size 73728)
    last unloaded kext at 3867942485260: com.apple.driver.AppleUSBOHCI 5.2.5 (addr 0xffffff7fa741c000, size 53248)
    loaded kexts:
    com.usboverdrive.driver.hid 3.0.2
    com.baltaks.driver.DoubleCommand 1.6.9
    com.delantis.kext.tcpblocknke 2.2.6
    com.globaldelight.driver.BoomDevice 1.1
    com.cyberic.SmoothMouse 1
    com.apple.driver.AppleBluetoothMultitouch 75.19
    com.apple.driver.AppleUSBDisplays 357
    com.apple.driver.AppleHWSensor 1.9.5d0
    com.apple.iokit.IOBluetoothSerialManager 4.1.2f9
    com.apple.driver.AppleMikeyHIDDriver 122
    com.apple.driver.AGPM 100.12.81
    com.apple.driver.X86PlatformShim 1.0.0
    com.apple.filesystems.autofs 3.0
    com.apple.driver.AppleHDA 2.3.5fc10
    com.apple.GeForce 8.0.6
    com.apple.driver.AppleMikeyDriver 2.3.5fc10
    com.apple.driver.AppleLPC 1.6.0
    com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport 4.1.2f9
    com.apple.driver.AppleUpstreamUserClient 3.5.10
    com.apple.driver.AppleSMCLMU 2.0.3d0
    com.apple.driver.AppleMCCSControl 1.1.11
    com.apple.driver.SMCMotionSensor 3.0.3d1
    com.apple.driver.AppleIntelHD4000Graphics 8.0.6
    com.apple.driver.AppleSMCPDRC 1.0.0
    com.apple.driver.AudioAUUC 1.60
    com.apple.iokit.IOUserEthernet 1.0.0d1
    com.apple.Dont_Steal_Mac_OS_X 7.0.0
    com.apple.driver.ApplePolicyControl 3.2.13
    com.apple.driver.AppleIntelFramebufferCapri 8.0.6
    com.apple.driver.AppleMuxControl 3.2.13
    com.apple.driver.AppleUSBTCButtons 237.1
    com.apple.driver.AppleUSBTCKeyboard 237.1
    com.apple.driver.AppleIRController 320.15
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
    com.apple.BootCache 34
    com.apple.iokit.SCSITaskUserClient 3.5.5
    com.apple.driver.XsanFilter 404
    com.apple.iokit.IOAHCIBlockStorage 2.3.1
    com.apple.driver.AppleUSBHub 5.5.0
    com.apple.driver.AirPort.Brcm4331 612.20.14
    com.apple.driver.AppleSDXC 1.4.0
    com.apple.iokit.AppleBCM5701Ethernet 3.5.0b9
    com.apple.driver.AppleFWOHCI 4.9.6
    com.apple.driver.AppleAHCIPort 2.5.1
    com.apple.driver.AppleUSBEHCI 5.5.0
    com.apple.driver.AppleUSBXHCI 1.5.1
    com.apple.driver.AppleEFINVRAM 1.7
    com.apple.driver.AppleSmartBatteryManager 161.0.0
    com.apple.driver.AppleACPIButtons 1.7
    com.apple.driver.AppleRTC 1.5
    com.apple.driver.AppleHPET 1.8
    com.apple.driver.AppleSMBIOS 1.9
    com.apple.driver.AppleACPIEC 1.7
    com.apple.driver.AppleAPIC 1.6
    com.apple.driver.AppleIntelCPUPowerManagementClient 196.0.0
    com.apple.nke.applicationfirewall 4.0.39
    com.apple.security.quarantine 2
    com.apple.driver.AppleIntelCPUPowerManagement 196.0.0
    com.apple.driver.AppleMultitouchDriver 235.29
    com.apple.driver.IOBluetoothHIDDriver 4.1.2f9
    com.apple.driver.AppleUSBAudio 2.9.0f6
    com.apple.driver.AppleThunderboltPCIUpAdapter 1.2.6
    com.apple.driver.AppleThunderboltDPOutAdapter 1.8.9
    com.apple.iokit.IOSerialFamily 10.0.6
    com.apple.kext.triggers 1.0
    com.apple.driver.DspFuncLib 2.3.5fc10
    com.apple.nvidia.nvGK100hal 8.0.6
    com.apple.NVDAResman 8.0.6
    com.apple.iokit.AppleBluetoothHCIControllerUSBTransport 4.1.2f9
    com.apple.driver.AppleSMBusPCI 1.0.11d0
    com.apple.driver.AppleSMBusController 1.0.11d0
    com.apple.driver.AppleHDAController 2.3.5fc10
    com.apple.iokit.IOHDAFamily 2.3.5fc10
    com.apple.driver.X86PlatformPlugin 1.0.0
    com.apple.driver.IOPlatformPluginFamily 5.3.0d47
    com.apple.iokit.IOSurface 86.0.3
    com.apple.iokit.IOBluetoothFamily 4.1.2f9
    com.apple.driver.AppleSMC 3.1.4d2
    com.apple.iokit.IOAudioFamily 1.8.9fc11
    com.apple.kext.OSvKernDSPLib 1.6
    com.apple.iokit.IOFireWireIP 2.2.5
    com.apple.driver.AppleGraphicsControl 3.2.13
    com.apple.driver.AppleBacklightExpert 1.0.4
    com.apple.iokit.IONDRVSupport 2.3.6
    com.apple.iokit.IOGraphicsFamily 2.3.6
    com.apple.driver.AppleUSBMultitouch 237.3
    com.apple.driver.AppleThunderboltDPInAdapter 1.8.9
    com.apple.driver.AppleThunderboltDPAdapterFamily 1.8.9
    com.apple.driver.AppleThunderboltPCIDownAdapter 1.2.6
    com.apple.iokit.IOUSBHIDDriver 5.2.5
    com.apple.driver.AppleUSBMergeNub 5.5.0
    com.apple.driver.AppleUSBComposite 5.2.5
    com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.5.5
    com.apple.iokit.IOBDStorageFamily 1.7
    com.apple.iokit.IODVDStorageFamily 1.7.1
    com.apple.iokit.IOCDStorageFamily 1.7.1
    com.apple.iokit.IOAHCISerialATAPI 2.5.1
    com.apple.iokit.IOSCSIArchitectureModelFamily 3.5.5
    com.apple.driver.AppleThunderboltNHI 1.6.3
    com.apple.iokit.IOThunderboltFamily 2.1.8
    com.apple.iokit.IO80211Family 510.4
    com.apple.iokit.IOUSBUserClient 5.5.0
    com.apple.iokit.IOEthernetAVBController 1.0.2b1
    com.apple.iokit.IONetworkingFamily 3.0
    com.apple.iokit.IOFireWireFamily 4.5.5
    com.apple.iokit.IOAHCIFamily 2.3.1
    com.apple.iokit.IOUSBFamily 5.5.0
    com.apple.driver.AppleEFIRuntime 1.7
    com.apple.iokit.IOHIDFamily 1.8.1
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.security.sandbox 220
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.security.TMSafetyNet 7
    com.apple.driver.DiskImages 344
    com.apple.iokit.IOStorageFamily 1.8
    com.apple.driver.AppleKeyStore 28.21
    com.apple.driver.AppleACPIPlatform 1.7
    com.apple.iokit.IOPCIFamily 2.7.3
    com.apple.iokit.IOACPIFamily 1.4
    com.apple.kec.corecrypto 1.0
    Model: MacBookPro9,1, BootROM MBP91.00D3.B08, 4 processors, Intel Core i7, 2.6 GHz, 8 GB, SMC 2.1f170
    Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 384 MB
    Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54333531533643465238432D50422020
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54333531533643465238432D50422020
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (5.106.98.100.14)
    Bluetooth: Version 4.1.2f9 11046, 2 service, 18 devices, 1 incoming serial ports
    Network Service: Wi-Fi, AirPort, en1
    PCI Card: Apple 57761-B0, sppci_ethernet, Thunderbolt@13,0,0
    PCI Card: pci11c1,5901, sppci_ieee1394openhci, Thunderbolt@14,0,0
    PCI Card: pci12d8,400e, sppci_usbopenhost, Thunderbolt@12,0,0
    PCI Card: pci12d8,400e, sppci_usbopenhost, Thunderbolt@12,0,1
    PCI Card: pci12d8,400f, USB Enhanced Host Controller, Thunderbolt@12,0,2
    Serial ATA Device: APPLE HDD HTS547575A9E384, 750.16 GB
    Serial ATA Device: OPTIARC DVD RW AD-5970H
    USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0x1a110000 / 3
    USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
    USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0x1d180000 / 3
    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0252, 0x1d183000 / 6
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x1d182000 / 5
    USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 4
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821d, 0x1d181300 / 8
     
  2. robvas macrumors 68020

    Joined:
    Mar 29, 2009
    Location:
    USA
    #2
    Willing to bet you have some 3rd party software/driver that's cuasing the issue - have you tried a CLEAN install?
     
  3. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #3
    I just did a clean install and reinstalled all of my software. But how am I to know which software it is? I just bought this computer to get WORK done, not tinker with it for 2 weeks to figure out which of my applications is tripping up the computer. Is there any way to use that info from the log to see what the application is?
     
  4. robvas macrumors 68020

    Joined:
    Mar 29, 2009
    Location:
    USA
    #4
    Go through that list of kext's one by one....

    I'd probably start by googling the name of each piece of software with '10.8.2 crashes' or something like that.
     
  5. duervo, Jan 21, 2013
    Last edited: Jan 21, 2013

    duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #5
    Get rid of USB OverDrive (or see if they have an update.)

    That program is notorious for causing kernel panics/crashes.

    There could also be an incompatibility between SmoothMouse and USB OverDrive. Both of those programs affect your mouse, so I would also look at removing one or the other.

    DoubleCommand too. Since that one affects keyboard, I would look at a compatibility issue between it and SmoothMouse and USB OverDrive (my money is on USB OverDrive, though.)

    I would look at those three first, updating or removing (I'd remove them) as necessary.

    The last two, Boom and TCPBlock, could be causing issues, but I would look at those first 3 first. Then look at updating Boom and TCPBlock (or removing them as well, if no updates are available.)
     
  6. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #6
    Will do- the only reason iI have usb overdrive installed is so I can have the back/forward buttons on my mouse functional. Smooth mouse to help my mouse actually feel somewhat usable; coming from a PC, I can't believe how imprecise the pointer is on OS X while using a mouse. It's actually gotten so bad that I am considering selling my newly purchased MBP and returning my Thunderbolt display. I do graphic sensitive work for a living and can't believe how poor the acceleration is implemented on this machine. The pointer also bounces around and feels "slippery".
     
  7. robvas macrumors 68020

    Joined:
    Mar 29, 2009
    Location:
    USA
    #7
    Get a Wacom tablet - adding all these goofy third-party tweaks to your machine is a recipe for disaster.
     
  8. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #8
    It's sad that I have to. I didn't think it would be an issue in OS X - especially since it's so dialed in in Windows. I prefer to use a mouse. I also have a magic mouse but the sensitivity is way too poor for every day use, I'll be returning it this week. I might pick up a higher end mouse just to see if that's the issue... Even though my Logitech mx518 works perfectly with my old Windows PC.
     
  9. robvas macrumors 68020

    Joined:
    Mar 29, 2009
    Location:
    USA
    #9
    All of our designers have a tablet.

    It's funny that you don't like the way the mouse pointer moves, people who are used to a Mac have the same complaint about Windows.
     
  10. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #10
    Maybe ill get used to it, but I really think it might be a problem with my machine. It lags fairly often, and when I want to do precision movements the pointer is shaky. Something has to be up, whether with my mouse or computer.
     
  11. Philscbx macrumors regular

    Philscbx

    Joined:
    Jan 4, 2007
    Location:
    Mpls Mn
    #11
    in Mouse Preferences - Try slowing down the Track Speed & Scroll.
    This could be the issue - just a guess.
     
  12. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #12
    I've never had an issue with mouse precision in osx. Fiddle around with the mouse settings and you should be fine.

    First step in debugging crashes is to take out 3rd party software. You can't really blame osx if a 3rd party writes crappy drivers.
     
  13. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #13

    Believe me, I've spent way too much time fiddling with these settings. On Windows, when I move the mouse- the pointer is an extension and follows it perfectly. If I move it slightly, it moves slightly and is precise. On OS X, the mouse jumps around when I try to move it in fine increments, and has inconsistent speed when moving across the screen. Hence the reason I have installed 3rd party software to try and rectify the issue.

    I removed a program called magicprefs and I am hoping that was the problem. Well see. Still though, apps like photoshop are performing worse than on my old HP Envy laptop, which is really surprising considering this MacBook is WAYY better spec-wise.
     
  14. Philscbx macrumors regular

    Philscbx

    Joined:
    Jan 4, 2007
    Location:
    Mpls Mn
    #14
    I should have noted - the last time I had jumpy motion - it was always low power on the device.
     
  15. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #15
    Mines plugged in 100% of the time.. I just dont know if it's my machine or if I have two incompatible/faulty mouses (mice?)
     
  16. Ccrew, Jan 21, 2013
    Last edited: Jan 21, 2013

    Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #16
    You're not on Windows. Not trying to be an ass, but if you try to make OSX be Windows you're in for a world of hurt. All the third party BS is your problem yet you're insisting you need it rather than listing what you're trying to do and let others help you with solutions. Clean OS and "all my software" means actual productivity software not 27 3rd party tweaks included.

    Bashing your Mac on a Mac board because "It's not like Windows" won't garner you a lot of sympathy, and better yet on a platform that's almost since it's inception been better at graphics work than any Windows machine. There's a reason companies like the one I work for exclusively use them in pre and post production.

    Doublecommand hasn't been updated since 2009 for starters.
    BoomDevice you show 1.1 loaded and they're at 1.5.1
     
  17. circa7 thread starter macrumors regular

    Joined:
    Jan 8, 2013
    #17
    Whoa whoa whoa. Back up a second. Im not trying to make my Mac act like Windows. I am talking about a very BASIC function here: mouse tracking. I'm not bashing on my Mac. Im trying to optimize it so it works for me. I just shelled out $2,500 on the computer and monitor- you think I'm going to talk it down? This is not a OS debate, this is a simple feature that should be a non-issue on both machines. The reason I mentioned that its perfect on my Windows machine is so I can accurately say that I have a reference point to base my problem and I am not just imagining it. Seriously, this shouldn't even be a problem. It is better at graphics work- I do web design and have used an iMac at work in the past and preferred over Windows. I have only had this MacBook Pro for 5 days and I am trying to fix the issue before I have to get rid of it. I need precision, and whether I have a a problem with this computer or all Mac's is something I need to discover. But like I said, I did not notice this with my iMac at my old job (2009 model).
     
  18. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #19
    But why install a bunch of software on it - that's not even of a vintage made for the OS no less - that goes to the core function of what you're having problems with, then do a reinstall and put it back on, rather than working through issues step by step?. You're going to be hard pressed to come here and find a soul that's going to back you up when many of us, myself included come from the Windows side and have found what you're experiencing to be the total opposite? The keyboard, trackpad and mouse functions on my MBP are far and away better than any Windows laptop I've ever owned barring maybe one of my boat anchor high end Thinkpads. And I run IT for a 3200 person organization, I see and evaluate a LOT of hardware.

    I mean doublecommand for instance. Other than keymap remap functions the whole purpose of that program was to supply two command keys... in the era of like TIger for an OS for chrissakes when current machines HAVE two command keys. And it was last updated 3 years before both Mountain Lion and your machine were released.
     
  19. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #20
    Try Better Touch Tool instead.
     

Share This Page