2012 MacBook Pro Trackpad Help!

Discussion in 'MacBook Pro' started by greenj, Jun 10, 2012.

  1. greenj macrumors newbie

    Joined:
    Jun 10, 2012
    #1
    SAFARI BASED FREEZE UP driving me crazy.

    How this is happening I cannot figure out!

    With my right hand, I just barely graze my finger over the trackpad (not even sure what motion I am using) while at the same time, with my left hand I am barry touching SOME KEY - do NOT know which one.

    Suddenly the page gets bigger for a second, the n blurry, then the whole page - whatever I am doing - usually on safari FREEZES. I cannot type anymore, and none of the clickable boxes work.

    This usually means I have to restart Safari and if I am typing on a page, i LOSE ALL The text!

    Does anyone know what the ^%$# is happening to cause this?

    This 2012 macbook pro trackpad is just WAY too sensitive.
     
  2. sjinsjca macrumors 68020

    sjinsjca

    Joined:
    Oct 30, 2008
    #2
    You are probably accidentally zooming the page ever so slightly.

    Next time it happens, try "pinching" the page so it bounces back to its original size. I'd bet it un-freezes.

    This happens to me, too, but I've gradually learned to pinch unresponsive pages, so it doesn't bother me as much as it used to. You could, in a pinch (ha ha), disable this gesture in System Preferences.

    Hope this helps.
     
  3. KylePowers macrumors 68000

    KylePowers

    Joined:
    Mar 5, 2011
    #3
    Woah 2012 MBP! :eek:

    How much RAM do you have? Perhaps Safari needs more resources
     
  4. sjinsjca macrumors 68020

    sjinsjca

    Joined:
    Oct 30, 2008
    #4
    Really doubt that. The symptoms match mine exactly-- Safari window inadvertently zoomed into an odd size, forms unresponsive.

    Seriously: Pinch and release, so the page bounces back into its default size. I'd bet real money this will fix the problem.
     
  5. arcite macrumors 6502a

    arcite

    Joined:
    Sep 6, 2009
    Location:
    Cairo, trapped in a pyramid with my iphone
    #5
    Go into SYSTEM PREFERENCES. > TRACKPAD. > under two finger scrolling, turn offscreen zoom.


    Easy.
     
  6. sjinsjca macrumors 68020

    sjinsjca

    Joined:
    Oct 30, 2008
    #6
    Yeah, that turns it off. But there are times when it's useful.
     
  7. greenj thread starter macrumors newbie

    Joined:
    Jun 10, 2012
    #7
    Thank you!! I think that worked. You saved me hours and hours of headaches! Major Good Karma pts for you!
     
  8. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #8
    holy smolly you got a 2012 already??

    like others said its that silly zoom feature you accidently hiting, just usint 2 fingers to pinch the screen and it will spring back to normal
     
  9. sjinsjca macrumors 68020

    sjinsjca

    Joined:
    Oct 30, 2008
    #9
    Safari behavior seems to have been fixed

    The behavior OP complained about, where an inadvertent zooming of a webpage would render it unresponsive to clicks, appears to have been ironed-out in some recent update. I noticed yesterday that Safari remains responsive even if the page is zoomed arbitrarily. I tried zooming to various degrees and could not reproduce the former behavior.
     

Share This Page