2012 MB Pro (non-retina) slow ethernet

Discussion in 'MacBook Pro' started by ceharrin, Jan 16, 2017.

  1. ceharrin macrumors newbie

    ceharrin

    Joined:
    Oct 1, 2012
    Location:
    In between the East and West coasts
    #1
    I have searched hi and lo for a possible explanation and cannot locate any info.

    Recently had Google Fiber installed at home and when I plug in via ethernet to the back of the Google network box, my macOS Sierra laptop maxes out about 250 mbs down but over 900 mbs up. A Windows work laptop easily gets 800+mbs up/down. Additionally at my google fiber installed office, I plugged in my MB Pro into the google network box and get the same results - 250 or so down but 800+ up.

    One thing I noticed is that in the past, if I plugged in my laptop at my office, I got over 900 mbs up/down. This was prior to upgrading to Sierra and connected with both El Capitan and Mavericks installed at the time. Our office got google fiber in June 2015 so It would seem that Sierra is the culprit as nothing else has changed with the laptop.

    I have fiddled with my ethernet settings on my laptop to no avail. Since I previously had over 900 mbs down and that I can still push 800+ mbs up, I must conclude that something in Sierra is the cause.

    Thanks -
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Try resetting PRAM/SMC. Also ensure that Sierra is fully up-to-date.

    If you're still having problems, you can create a new Administrator account. This will just be for diagnosis purposes, to see if the problem persists through a new user.
     
  3. ceharrin thread starter macrumors newbie

    ceharrin

    Joined:
    Oct 1, 2012
    Location:
    In between the East and West coasts
    #3
    Reset NVRAM but no help. Thanks for the suggestion though.
     

Share This Page