2012 MBP classic - can no longer get handbrake to work

Discussion in 'Apple TV and Home Theater' started by thecounthahaha, Nov 24, 2012.

  1. thecounthahaha, Nov 24, 2012
    Last edited: Nov 24, 2012

    thecounthahaha macrumors regular

    Jul 17, 2010
    Hi guys,

    I've recently moved from a 2009 snowleopard machine running vlc 1.1.5 and handbrake perfectly. Annoyingly I've still not managed to get it working on my new machine on Lion.

    Maybe wrongly, I updated to vlc 2.x.x before even trying handbrake as I was unaware of the issues this causes. I got a "No Valid Source Found" error in handbrake.

    I googled this and downloaded the patch to "fix" vlc 2.0 and handbrake, but it didn't work, either with libdvdnav on or not.

    So I uninstalled handbrake using appcleaner and reinstalled the latest version downloaded off the website. Still no luck. I reinstalled the patch again just in case. No luck again.

    So I've now uninstalled both vlc and handbrake using appcleaner and used an old dmg file of vlc 1.1.5 and the new handbrake.

    I deleted the preferences of vlc 1.1.5 using the included delete preferences app, and still nothing...!

    What am I doing wrong?


    I can't find how to delete, but I kept trying to work out what was wrong.

    Turns out I hadn't used the dvd drive to watch something yet so was still on region 6 (China)..! Setting it to 2 as I use fixed everything. Hooray!

Share This Page