2012 MBP with SSD - failed - help please?

Discussion in 'MacBook Pro' started by smithy10, Sep 7, 2016.

  1. smithy10 macrumors newbie

    Joined:
    Sep 7, 2016
    #1
    Hi there

    I have the above that was working fine until I powered off one night and now it wont turn on.

    If i try to boot it I get the apple logo then the status line. It takes an age to work through this, and then the screen goes blank. I did some searching and tried a couple of commands like safe mode etc. But still no joy.
    I also took the back off and reseated the SSD memory chip and no change.

    So a few questions:

    1.Any other checks or any ideas to try and get this to boot. Someone mentioned using a thunderbolt cable from another mac (I have a mac mini) to boot?
    2. It looks like I need to buy a new SSD - any suggestions where?
    3. If I do replace the SSD how do i get the OS back on, how do I get the machine to boot if no partitions?
    4. I think it backed up to my apple router/HD, any way of checking this?

    Any other advice would be much appreciated please?

    Thanks in advance.
     
  2. Shamgar macrumors regular

    Joined:
    Jun 28, 2015
    #2
    Try booting from the recovery partition. Hold Command R on startup. It may not be the drive per se. This would give you access to the Disk Utility. You could also connect your MBP by Thunderbolt to the Mac mini, then boot the MBP while holding T. This will allow you to run utilities from the mini against the MBP drive.

    What I would typically try is making a USB installer. Download the OS X installer from the App Store on your Mac mini and then use Disk Maker X to prepare a USB drive installer. You can then boot off the USB drive from the MBP by holding C during start up. Run Disk Utility from there. This is also how you install on a new drive if it comes to that.

    To check your backups, go to Network in the Finder on your mini and open up your time capsule. Look in the backups folder for your MBP's name, and then check the dates of the enclosed folders.

    For the 2012 retina MBP, your best bet for a replacement SSD is a Samsung 850 Evo mSATA on an adapter card. I went with one like this. The 1TB model may not fit properly, but I had success with the 512GB model.
     
  3. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    It could be the ribbon cable that connects the SSD to the motherboard.
    These are quite fragile and there have been numerous reports of failures.

    You can check this by taking the SSD -OUT OF- the MB, closing it up, then connecting the SSD via USB and try to boot that way.

    If the MacBook boots and runs normally connected via USB, vis-a-vis problems when connected internally, that would point towards the internal ribbon cable.

    Go to ifixit.com to see what's involved in changing it.
    Also, they have the part number there, and may even be able to sell you the cable if you need one.
    Another source for the cable could be ebay, amazon, etc.

    It could also be a software problem (OS) with the SSD, not necessarily a hardware problem with the drive itself.

    This is why I always, ALWAYS recommend that others keep at least one cloned copy or otherwise "fully bootable" drive around, for emergencies such as you're experiencing now...
     
  4. lamina macrumors 68000

    lamina

    Joined:
    Mar 9, 2006
    Location:
    Niagara
    #4
    I had the same problem. I thought it was my SSD. I even sent it away for replacement. Turns out it was the cable. The replacement was cheap and installed really easily.
     
  5. smithy10 thread starter macrumors newbie

    Joined:
    Sep 7, 2016
    #5

    Thanks for the useful info here. I didnt know about the issue with the ribbon. Can I ask how I connect the SSD to the USB drive, I assume I need some kind of adaptor?
    --- Post Merged, Sep 13, 2016 ---

    Hi There, I must say thank you to all for taking the time to reply to my question (especially Shamgar). I tried the steps above, holding down command R didnt work, so I will try the USB option. Thanks will keep you all posted.
     
  6. jerryk, Sep 14, 2016
    Last edited: Sep 14, 2016

    jerryk macrumors 68030

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #6
    You need a USB enclosure. There are a lot on Amazon. Here is one I own, works OK.

    https://www.amazon.com/Inateck-Inch...&qid=1473860849&sr=1-4&keywords=ssd+enclosure

    Most of them are tool free. Just insert the drive and go. Takes about a minute to install.

    They have a pad that you may or no need depending upon the thickness of your SSD. Just make sure the SSD aligns with the port and is not bending up or down.
     
  7. Shamgar macrumors regular

    Joined:
    Jun 28, 2015
    #7
    Just to clarify, is the computer in question a 2012 classic MacBook Pro, or retina MacBook Pro?
     
  8. smithy10 thread starter macrumors newbie

    Joined:
    Sep 7, 2016
    #8
    I think it is a 2012 classic with SSD. Model A1398
     
  9. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #9
    I believe Model A1398 is a retina mode, so its not "classic" The easiest way to tell, is if your MBP has an optical drive or not. No DVD drive means you have a rMBP
     
  10. smithy10 thread starter macrumors newbie

    Joined:
    Sep 7, 2016
    #10
    You are right, I just did some further digging, it is a Retina model without a drive.

    Also a further update on debugging this issue ...

    I tried to plug the SSD into an external USB holder. When I plugged this into my mac mini I get a warning stating that usb device is using too much power?

    I'm really stuck without this working it is a real pain. Someone mentioned downloading OS X and creating a boot drive. Can someone clarify how to do this?

    Thank you
     

Share This Page