2013 15" MBP Retina Slow For No Reason

Discussion in 'MacBook Pro' started by Tristan L., Mar 15, 2016.

  1. Tristan L. macrumors newbie

    Joined:
    Mar 15, 2016
    #1
    Hi!
    A few weeks ago my early 2013 15" Retina started acting really slow. Not UI lag, just constant mini freezes, often with the beachball.
    Obviously, I checked the activity monitor, and everything seemed fine - 97% idle CPU, 1gb active RAM, 229GB free on the SSD.
    It got so bad that I can't use it. Here's what I've tried-

    Repairing Permissions
    Running disk utility first aid
    SMC Reset
    PRAM Reset
    Erased the drive and installed Lion
    Erased the drive again and reinstalled fresh OSX El Capitan
    Ran SSD Trim Enabler

    Nothing. Still slow. I figured I must have some sort of hardware issue, perhaps with the connection between the SSD and the logic board. I would replace the hard drive cable if it had one.

    Here's where it gets interesting- I installed OSX on an external HDD in an enclosure and boot from it, and it's reasonably quick. I've been living with this external HDD for weeks.
    Anyway, I run the blackmagic speed test on the SSD mounted as an 'external' drive, and I get good results. (200+MB/s)
    So I try booting from the SSD again, and it's slow still. I run the speed test while booted on the SSD, and it's painfully slow. (1-2mb/s)

    So I'm at a loss. It seems to not be a hardware issue, since the SSD was fast when tested as an external. It's only slow when booted from it.
    Is there any other steps to take?

    Thanks!
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    It looks like you have tried many things to resolve the problem. There were a few unclear items that I could not find the answers to in your post.

    Did you migrate old data/preferences/applications to you new OS installs on the internal or were they completely clean installs?

    Is the OS on the external enclosure a clean install OS without everything that is installed on the internal? I'm wondering if you have some old installs or startup items causing problem on the internal and not the external.

    Why are you running SSD Trim enabler? Isn't Trim natively supported on your internal rMBP flash drive?

    Can you try creating a new User account when booted from the internal and try booting from the new account to test the performance?
     
  3. Tristan L. thread starter macrumors newbie

    Joined:
    Mar 15, 2016
    #3
    Hi, thanks for the suggestions!
    Indeed, I got the computer without a hard drive so the SSD is a non native OWC drive.
    The installs were fresh and there was no transferred installs or settings.
    The external HDD is running from the backup I made from the internal SSD before I wiped it.
    I will try your new user suggestion though!

    I'm thinking the only way to test the hardware would be to put this SSD into a different computer and boot from it to see if it's still slow..
     

Share This Page