Resolved 2013 iMac Sleep Settings

Discussion in 'iMac' started by madsci954, Jul 18, 2014.

  1. madsci954, Jul 18, 2014
    Last edited: Jul 18, 2014

    madsci954 macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #1
    I just got a 2013 iMac (not brand brand new, couple months old I bought off a friend) loving it so far. I'm trying to configure good sleeps settings for it and running into some troubles.

    I have it set to sleep every night at 11 pm local time, and wake manually. I only put it to sleep when I leave the house, otherwise it idles and the screen just goes to sleep. There are times I'm not using my iMac right away and it remains asleep. This is working good, it's when it wakes up is when the issues start.

    My iMac is wired to a 5th gen Airport Extreme with a connected USB drive for TM backups. When it wakes, more often than not, I get connection errors and either have to a) launch Finder, go to my AE in Shared, and reconnect or b) when "a" doesn't work have to restart the AE from the Airport Utility iOS app and reconnect. Even when these connection issues don't occur, the backups don't run, even though I have PowerNap enabled.

    Also, when sleeping, my Apple TV cannot see my iTunes content downloaded on my Mac, nor can the library be seen from the iOS Remote app. When the Mac is awake, the content can be seen without issue.

    So my questions are what settings need to be enabled or disabled to fix my problems, and what can I do about the AE disconnects?
     
  2. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #2
    You need to connect the TM drive directly to the iMac and not your AE. TM was never intended to work on a network unless you have a Time Capsule. While some have had some luck connecting an external HD to their AE and using it for TM, inevitably they run into trouble and the answer is ALWAYS the same, connect the drive directly to the Mac.
     
  3. madsci954 thread starter macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #3
    Yeah, I knew that was an issue, I guess I can make due. What about the iTunes content issue?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Time Machine backups to a USB drive attached to the older pancake shaped Airport Extreme like yours is not supported by Apple and will cause the buggy behavior you are experiencing.

    It is supported on the new sixth gen tower shaped Extreme model.

    The Mac will need to be awake for this to work. Go into the energy saver pane in system prefs and check "wake for network access" and that should allow the devices to wake up the Mac to serve up iTunes content.
     
  5. madsci954 thread starter macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #5
    I have that box checked, and my iTunes library still disappears from the Remote app. Is there another option I have to check?

    Also I just realized, the Airport is not creating the wifi network, a Cisco wifi router is plugged into the modem, and the AE is wired to the router. Could that be the issue?
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Yes. I don't think wake on LAN is going to work across two routers.
     
  7. madsci954 thread starter macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #7
    Okay, thanks for all the help Weaselboy.
     
  8. TinHead88 macrumors regular

    TinHead88

    Joined:
    Oct 30, 2008
    #8
    Just to add some info to this thread...

    I am using a usb hdd connected to my 4th gen AE to backup 2 iMacs and a MacMini.

    For this to work your AE has to be the router though. Also, some variations in the way drives themselves sleep could cause issues.

    FWIW in Airport Utility I have enabled file sharing, chosen device password as security for the disk and ticked remember in keychain.

    Seems to be working fine for me.
     

Share This Page