2013 MacBook Air - Ignoring HibernateMode setting?

Discussion in 'MacBook Air' started by Brian Y, Oct 3, 2013.

  1. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #1
    Hi All,

    I've got a 2013 MacBook Air cause I got sick of carrying around my 15" lump - and the first thing I did, as with my retina, was disable it hibernating. It still works absolutely fine on my 2012 Retina, but on this MacBook Air - nada.

    After 3 hours, the machine wakes itself up - and continuously tries to write to the (unwriteable) sleepimage file - thus causing massive CPU usage, and excessive heat whilst it's in my bag.

    Any ideas - everything standby related is set to 0, and hibernatemode is 0.
     
  2. H264 macrumors newbie

    Joined:
    Oct 21, 2013
    #2
    Strange - I have the exact same problem, but on my Macbook Pro Retina.

    After upgrading to 10.8.5, it takes 20-30 seconds to sleep. I found it was creating an 8GB sleepimage, and it goes to hibernate after 3 hours, despite pmset hibernatemode being set to 0, and autopoweroffdelay set to 86400 (24 hours).

    I found a couple of ways to disable sleepimage
    1) set hibernatefile to /dev/null or
    2) chflags -uchg /var/vm/sleepimage after creating a 0 byte sleepimage

    In both cases though, the Macbook still takes 20-30 seconds to go to sleep, despite not being able to create the sleepimage. I have yet to try what happens after 3 hours if I disable sleepimage, but I suspect it will hibernate without it, causing a reboot from fresh.

    My dad's Macbook Air, on the other hand, also with OSX 10.8.5, with hibernatemode being set to 3, goes to sleep without delay, and without writing sleepimage.

    So frustrating!
     
  3. H264, Oct 22, 2013
    Last edited: Oct 22, 2013

    H264 macrumors newbie

    Joined:
    Oct 21, 2013
    #3
    I solved my problem .. I found this article "Addressing slow sleep times in OS X"
    http://reviews.cnet.com/8301-13727_7-20077964-263/addressing-slow-sleep-times-in-os-x/
    I tested sleep after each step, and it went back to normal after resetting PRAM with Option-Cmd-P-R during boot chime. I will never know what caused it or exactly why PRAM needed resetting.

    EDIT: It did not work for long. After a couple of reboots it went back to the old 20 second delay before going to sleep. And clearing PRAM again makes no difference now. With hibernatemode set to 0 it does not write a new sleepimage. I have no idea what takes so long then to enter sleep mode. I still have to wait overnight to see if it shuts down or tries to hibernate.
     
  4. H264 macrumors newbie

    Joined:
    Oct 21, 2013
    #4
    I think I found the problem this time, and it appears completely irrelevant for the original thread starter. I am sorry about confusing your question.

    It turns out having the Chrome browser open is what is causing the delay in going to sleep. I verified this problem on both my Macbook Pro and my dad's Air.
    Also discussed here in fact:
    http://forums.macrumors.com/showthread.php?t=1649152

    I still have to figure out why pmset autopoweroffdelay and hibernatemode are ignored overnight (or after 3-4 hours), but that will take much longer to figure out.
     

Share This Page