2013 MBA USB Issues?

Discussion in 'MacBook Air' started by acote, Aug 8, 2013.

  1. acote macrumors newbie

    May 10, 2011
    Hello all,

    I'm having some problems with my recently purchased Macbook Air concerning its ability to work with USB devices. Here is the story:

    I am a long-time DJ who has recently decided to take his set up to a more digital domain. So, I traded in my 7ish year old MBP for a new MBA (13 inch, i7, 8GB, 128GB SSD) recently in the hopes of creating a smaller, more portable, modular setup. To do so, the MBA needs to work with 3 USB devices: 2 MIDI controllers and 1 external HDD. The HDD is a WD Passport 1 TB. The MIDI Controllers are a Traktor Kontrol S4 and an Allen & Heath Xone:K2.

    Originally, my plan was to run all these devices through an externally powered USB 2.0 hub. However, when I did so, anywhere from 10-60 mins into playing music, the USB devices just stopped working. They still had power (the S4 is externally powered in addition to the externally powered USB hub) but they could no longer control anything. The S4's usb connection indicator was flashing, signalling no USB connection. In addition, the HDD was technically "mounted" but, when clicking on it in Finder, it's as if nothing is there. I got no message from the MBA saying anything about too much power being drawn or devices being ejected. It just stopped working.

    So, my first thought was it was the USB hub, as it was older. So, I connected the S4 and HDD directly to the USB ports on the MBA. Once again, the same problem occurred. My next thought was that one of the MBA USB ports was able to put out more power than another (I'm under the assumption that the S4, even though externally powered, still takes more power than the HDD), so I switched which USB ports they were in. Still, the same problem occurred.

    So I tested it in my IMAC desktop and, thus far, it has been working perfectly. So I returned the MBA and got a new one, thinking it was a defective one. Sadly, trying it again tonight with a new MBA of the same specs, the same problem occurred. So now, I am out of ideas. Does anyone know what could be causing this problem and, if so, how to fix it? I can still return my MBA, but I would really like to keep it if possible. It does everything else I want (for school and whatnot) really well. It's just having this one, very frustrating issue.

    Thanks for any help you can offer. If this is an actual problem with the MBA models, would it be best for me to wait to get a new MBP?

  2. checkitout macrumors member

    Nov 2, 2009
    This may be unrelated, but I have seen problems with power supply leakage currents upsetting USB connections. This may seem totally random if you don't know what it is. Are you running off a mains power supply when this happens? Try checking if the same problem occurs on battery.
  3. Boyd01 macrumors 68040


    Feb 21, 2012
    New Jersey Pine Barrens
    I use a bunch of USB devices simulaneously on my 2013 11" MBA and have no issues. I'm using an Akai EIE Pro 4 channel audio interface that includes a powered 3 port hub. I have a Korg control surface plugged into that and also use a variety of USB hard drives (including a 1TB passport), an HP printer and various flash drives.

    I'm also using a really old (2006?) Apple Cinema display that includes a two port hub and I connect a keyboard and mouse there.

    Previously I had a 2011 MBA and used even more devices with it via a 6 port powered hub. When I got the 2013 MBA (about a week ago) I initially had issues with my Akai EIE pro. Was getting clicking and popping sounds through the speakers, but updating to the new driver fixed that. However, Logic Pro was hanging for almost two minutes every time I started it. I found a firmware update for the interface on Akai's site, and after installing that I have had no problems.

    Make sure that all your drivers are up to date, and also check to see if there are any firmware updates for the USB devices themselves.
  4. acote thread starter macrumors newbie

    May 10, 2011
    A quick update.

    I have updated all the drivers and firmware that I could find. The same problem still occurs.

    In addition, I have tried it without the power cord and the same thing still happens.

    So, I'm back to square one. Does anyone have any other ideas as to what could be causing this problem? If no, I guess I'll just have to return the MBA and hope the new MBP doesn't have the same problem.

  5. mattferg macrumors 6502

    May 27, 2013
    Have you disabled ALL sleep options, hard drive sleep screen dimming etc etc?
  6. scaredpoet macrumors 604


    Apr 6, 2007
    I would suggest opening up the Console app (it's in Applications -> Utilities) and running the devices, letting the failure happen. When it happens, look at the log that appears in console for any clues. hopefully at the point the disconnects happen, the logs will explain (at least to someone technical) what's going on.

    It might also help to post the relevant error messages here to see if anyone here can figure it out. If not, maybe someone in the OS X forums can help.
  7. acote thread starter macrumors newbie

    May 10, 2011
    I disabled all sleep options and the problem still occurred, sadly.

    In response to Scaredpoet, thus far there have been no error messages. Everything just stopped working. However, I ran the console application and, when the error occurred, three messages came up. They are below:

    • 8/12/13 4:02:27.000 PM kernel[0]: vtd[0] fault: device 0:20:0 reason 0x6 R:0x480000

    • 8/12/13 4:02:27.000 PM kernel[0]: com_caiaq_driver_TraktorKontrolS4_NIUSBAudioEngine(0xffffff80ed2af000): unable to submit irp for writing (0xe00002ef (UNDEFINED))

    • 8/12/13 4:02:27.000 PM kernel[0]: USBF: 465.285 AppleUSBXHCI::pollEventRing2 (bottom) - HSE bit set - USBSTS: 0x00000005

    So, it looks to me like the S4 is the problem, though I'm not sure what is happening. Can anyone make sense of these messages? I have a call with Apple support tomorrow and will be sure to ask about them. Thank you so much for the Console suggestion. It has at least given me some information to work with.

  8. mattferg macrumors 6502

    May 27, 2013
    Does the issue occur with just the A+H and the HDD plugged directly into the Air?
  9. keff2k macrumors newbie

    Aug 29, 2013

    I had the exact same behavior of my 2013 macbook air with kontrol s4 in cruise mode. also the error messages in console.app were the same.

    my config:
    MBA 2013 13", 8GB RAM, i7, 256 SSD.
    Traktor Pro 2.6.3, Kontrol S4

    I spent 5 days an nights with fatiguing research in forums, try and error, using external usb2-hubs, changing sleep options with pmset in terminal... and so on! finally i found the solutions which is working for me.

    I always used the latest S4-Driver provided by NI, Version 2.5.3!

    Yesterday evening i downgraded the driver to Version 2.5.1 and since then traktor is working perfectly in cruise mode! this is for almost 15 hrs now... new record ;-) i have S4 directly plugged to the MBA, without any usb-hub in between.

    here you can download the 2.5.1 driver for S4: http://co.native-instruments.com/index.php?id=freeupdates#Traktor_Kontrol_S4

    hope this is gonna help you out!
  10. CarlosRafael macrumors newbie

    Sep 3, 2013
    Not Solved

    I'm having the same problem.

    I have the version 2.5.3 .. I tried to install the 2.5.1 on top, but the kontrol S4 keeps going out alone. :(:mad:
  11. Soundathlet macrumors newbie

    Sep 20, 2013
    Using Traktor S4 without the external power adapter

    I have the same problems with my Mid 2013 MacBook Air (i7, 8GB, 512GB SSD) and the Traktor S4. My experience was, that using the S4 without the external power adapter might be a first aid solution. When I use it without the external powering, everything works perfect. Even after 3,5h of use. I've installed all the latest Traktor drivers and updates. Hopefully Native Instruments is solving this serious issue. It should be a certain compatibilty problem between the S4 and the Mid 2013 MacBook Air. Together with my old 2007 MacBook everything works perfectly.
  12. apexist macrumors newbie

    Nov 1, 2013
    same problem

    I have an exactly same problem with my MBA 2013(mid).

    I also purchased MBA for DJing but really disappointed with this.

    My set up is ...

    Traktor Scratch Pro 2.6.3
    NI Audio 8 DJ with the latest firmware (2.6.0 fixed issues with kernel panic on MBA 2013 and support mavericks)
    Denon CDJ SC2900 and SC3900
    DJM 800

    2 CDJs and Audio8DJ connected to MBA on USB port.

    CDJs have its own power and Audio8DJ uses only USB bus power.

    Everything is fine with this setup. Timecode signal is steady and has no latency.

    But after I start mixing, suddenly all usb connection goes out randomly.

    Sometimes it took 5min, sometimes 30min.

    No MIDI signal, No Sound output

    MBA's console show me messages ...

    2013. 11. 2. 오전 2:09:59.000 kernel[0]: USBF: 3423.591 AppleUSBXHCI::pollEventRing2 (bottom) - HSE bit set - USBSTS: 0x00000005
    2013. 11. 2. 오전 2:09:59.000 kernel[0]: vtd[0] fault: device 0:20:0 reason 0x6 R:0x480000

    I have researched every forums (NI, Apple) but couldn't find any solution yet.

    But there was so many posts about issue about USB3.0 on new MBA.

    Plz let me know if you have a solution :)
  13. djayala macrumors newbie

    Jan 18, 2014
    I'm having the same problem, using the same settings! Would anyone already managed to solve the problem? unfortunately it is impossible to confirm the system, and can run 30 5 or 60 minutes.
  14. frarees macrumors newbie

    Jan 18, 2014
    I'm having the exact same problem. I have a MacBookPro11,1 (i7, 16GB) and after a while using Traktor S4 and Traktor Pro (version 2.6.7) it crashes:

    18/01/14 16:38:30,000 kernel[0]: vtd[0] fault: device 0:20:0 reason 0x6 R:0x5c2000
    18/01/14 16:38:30,000 kernel[0]: com_caiaq_driver_TraktorKontrolS4_NIUSBAudioEngine(0xffffff81b434e000): unable to submit irp for writing (0xe00002ef (UNDEFINED))
    18/01/14 16:38:30,000 kernel[0]: USBF:    2717.365    AppleUSBXHCI::PollEventRing2 (bottom) - HSE bit set - USBSTS: 0x00000005
    Is this an Apple or Native Instrument problem?


Share This Page