2013 MBA Wi-Fi having problems for everyone?

Discussion in 'MacBook Air' started by dmk1974, Apr 27, 2014.

  1. dmk1974 macrumors 68000

    dmk1974

    Joined:
    Sep 16, 2008
    #1
    My wife has been telling me how her Wi-Fi and internet seem to drop on her 2013 MBA 13" laptop. Basically, when opening both Safari or Chrome, it will stall when loading the home page (or any other web page). Seems somewhat intermittant too...I've verified it myself.

    All updates are current. I've even swapped routers and for both had her connect to 2.4 and 5 GHz bands (seen the issue in all cases). Plus, it's only her laptop with the issue. My 2013 rMBP has zero problems and none of the other Windows PC's, iPod, iPads, iPhones or anything else has a problem.

    I found this LONG thread as well on the Apple forums (didn't read it all of course) but seems to specifically plague many MBAs.

    https://discussions.apple.com/thread/5100655?start=2055&tstart=0

    Sure hope there's some resolution out there. I may re-install everything and even take it to the Genius Bar if no luck, but at the Apple Store they almost never replicate the problem.
     
  2. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #2
    My 2013 MBA (purchased last July) has never had wifi problems, so clearly it isn't "everyone". There was a lot of discussion on this topic last summer and fall, but it doesn't come up very often now. Seems like it may have been hardware-related on some machines and by now most of the bad ones have been swapped out.

    If you can document that this is happening, take it to the Apple Store and see if they will repair/swap it.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    I have that exact same MBA and no issue at all with wifi, so it does not seem to effect them all.

    Have you tried some of the things mentioned in that thread like deleting the network profile and make a new one?
     
  4. lina231 macrumors regular

    Joined:
    Aug 7, 2013
    #4
    Ive only had a very few problems with my wifi dropping. What worked for me is turning my wifi off and then turning it back on. Sometimes I had to do this a couple of times, but thats what worked for me.
     
  5. Tangolima600 macrumors newbie

    Joined:
    Mar 13, 2011
    #5
    I'm having notable wifi problems in the past month after owning it since November. It will randomly stop functioning and I am left with 'resolving host' in a web browser (safari and chrome) followed by a time out. I can stop and start my wifi radio on the macbook and it comes back right up and will work for one hour, half hour, or 15 minutes. I own the mid 2013 model with current drivers and updates. No other devices exhibit the same symptoms of the macbook. Has anyone got good results from taking it to their local Apple store?
     
  6. GeekGuys macrumors regular

    Joined:
    Mar 13, 2009
    #6
    Some things to test would be

    DNS settings on her laptop IP settings. If these are incorrect this would cause resolution delays on webpages

    Make sure Server Certification Revocation Checks are disabled, as this can slow web browsing down a lot.

    In Safari, this is handled by Keychain. In Chrome and Firefox these are advanced settings.

    Just a few thoughts
     
  7. drenline macrumors 6502a

    drenline

    Joined:
    Aug 8, 2010
    #7
    do you have your bluetooth enabled on your machine?
     
  8. dmk1974 thread starter macrumors 68000

    dmk1974

    Joined:
    Sep 16, 2008
    #8
    For my wife's MBA, Bluetooth has always been off since she has no devices connecting to it.
     
  9. Orr macrumors 6502

    Orr

    Joined:
    Oct 8, 2013
    #9
    Had a new 13" Haswell Air when they first came out last summer and never experienced any wi-fi drops during the three months. A select group of them definitely appear to be afflicted, but summarizing that the issue applies to everyone based primarily on your single machine plus an internet thread is pretty lacking.
     
  10. dmk1974 thread starter macrumors 68000

    dmk1974

    Joined:
    Sep 16, 2008
    #10
    Well, I TM backed up my wife's MBA tonight and then did the full wipe and restore of Mavericks from scratch (the 1.5 hour download and setup). Damn thing still seems slow and stalls a lot in Safari!

    It almost seems like it can't walk and chew gum at the same time. If I'm transferring a file or opening 2 web pages concurrently, it just sits there stalled. If nothing else is going on, then maybe 50-60% of the time it will load.

    Very frustrating...especially after a clean install.

    And no issues at all with my rMBP, other PCs in the house, or the slew of iOS devices.
     
  11. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #11
    My wife has a new 13" MBA and has no problems with internet wi-fi, and she has used it in several different locations and networks.
     
  12. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  13. dmk1974 thread starter macrumors 68000

    dmk1974

    Joined:
    Sep 16, 2008
    #13
    I actually just replaced what I had a few days ago (Fri 4/25) and have had the problems with both routers. The previous was a 4th gen Apple Time Capsule 2 GB. I even tried connecting the MBA to separate 2.4 and 5 GHz bands. The router I've been using the past few days is a Netgear R6250 and primarily using the 5 GHz ac band.
     
  14. Maui19 macrumors regular

    Joined:
    Jul 16, 2007
    #14
    I have the 2013 MBA and don't have any of these problems. However my buddy has an identical machine and does have this problem. It has been in for repair twice, and I think Apple is about ready to swap his for a new one.
     

Share This Page