2014 Mac Mini display problem

Discussion in 'Mac mini' started by Florals, Nov 12, 2014.

  1. Florals macrumors member

    Joined:
    Jul 19, 2013
    #1
    I'm hoping someone on here can help me out with this problem I've been having with my new mini.

    When my mini wakes from sleep, the colours on the screen are extremely distorted and the screen is pixelated; see the attached photo. The colour distortion/pixelation looks different every time the mac is woken up. I'm connecting my monitor (brand new Samsung S24D390) via a DP to VGA connector. I've tried three different connectors (one unofficial, two official) and all seem to produce this problem intermittently. Removing and re-inserting the DP to VGA adaptor solves the problem, but I shouldn't have to be doing that all the time.

    Does anyone have any ideas as to what this could be causing this, and how I could fix it?
     

    Attached Files:

  2. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #2
    Have you tried connecting DP to DVI? There might be some noise in unscrambling the digital to analog signal of DP to VGA. Just a hunch as I've seen similar issues with just digital to analog conversion (not on mac mini though).

    The mac mini might also be reading the color space as YCbCr while VGA only supports RGB so maybe see if you can force RGB on your mac mini first.
     
  3. Florals thread starter macrumors member

    Joined:
    Jul 19, 2013
    #3
    Sadly the monitor only has two inputs: HDMI and VGA. HDMI looks really crappy due to scaling options, so VGA is my only hope.

    I'll try forcing RGB, though, that sounds like it could work.
     
  4. justinTlME macrumors 6502

    justinTlME

    Joined:
    Jul 21, 2014
    #4
    I'm not having that same distortion but I have been having a lot of issues waking my 2012 mini up from sleep. I think it's a Yosemite issue...
     
  5. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #5
    Two options:

    1. Can't you turn off overscan? I've haven't looked in Yosemite, but this used to be an option in prior versions...
    2. You might also try MDP -> DVI -> HDMI. Since DVI does not introduce overscan as an option, it should automatically fix your problem.
     
  6. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #6
    Personally I'd probably try HDMI again, and looking on the help pages for making sure the Samsung monitor is set up so it doesn't overscan/underscan the image and make a poor quality display.

    Likely a lot of threads like these for Samsung products.

    https://discussions.apple.com/thread/2205894?tstart=0

    http://apple.stackexchange.com/ques...if-the-imac-is-connected-to-an-hdtv-and-using

    I'm using an AOC monitor via HDMI, which takes awhile to wake when the Mini wakes up -- but it also has heat sensitive buttons on the front, so waking it is as easy as touching the bezel of the monitor.
     

Share This Page