2014 MacBook Pro Retina - VERY SLOW USB 3.0, no longer can clone to external drive

Discussion in 'MacBook Pro' started by striders, Dec 7, 2014.

  1. striders macrumors 6502

    Joined:
    Mar 11, 2009
    #1
    For all my previous MacBook (Air and Pro) with Maverick, I always backed it up using Carbon Copy Cloner (CCC). For those who doesn't know, CCC can create a bootable image of your Mac. So you can take the external drive, plug it is into any Mac, boot up and VOILA! You got your machine right there. Much better than Time Machine.

    Anyways, I tried to do an image on my MacBook Pro Retina 2014 with Yosemite and this is what I found out:

    1). USB 3.0
    Very, very slow. I cannot get more than 40 MB Read / Write. Tested with major flash drive proven to have high speed:

    - 256 GB PNY USB 3.0 Turbo Flash Drive (4.5 stars - 1200 reviews in Amazon). Other reviewers (see the Amazon URL) got 180 MBps Read and 80 Mbps Write.

    - 64 GB SanDisk UltraFit USB 3.0
    (4 stars - 200 reviews)

    And this brings me to the next problem...

    2). Cloning
    I can clone my new MBP with Yosemite as usual, but then booting up from the flash drive is SUPER SLOW, like this:
    - Apple icon shown with progress bar --> 10 minutes
    - Login screen shown - click on the Password box --> beachball for 5 minutes
    - Got to desktop --> beachball for 5 minutes
    ... you got the idea

    With Maverick, all the cloned image boot up fast and is usable, as if I the image is installed in the internal hard drive.

    I tried both SuperDuper and Carbon Copy Cloner - same exact results.

    So my questions:
    1). Is the slow USB 3.0 speed a common problem or my MBP just have bad ports (both of them?)?

    2). Any idea about the cloning issue? I am leaning towards Yosemite OS as the main culprint, since Maverick works OK, but want to get the expert opinion.
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    You do have CCC 4.0, right?

    "Carbon Copy Cloner 4.0.2 (and later) is qualified on OS X Yosemite."

    Dunno why yositime is slow for you, perhaps a clean install. You've done the usual fix permission ad repair drive thing?

    Otherwise you may have to re-intall yositime; perhaps a clean copy.
     
  3. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #3
    Yes, I have the latest version. Also, I did boot up to system recovery (Command + R) and ran Disk Utility from to there to fix permission and verify disk. Oh, the MBPr is also new, I haven't installed too much apps other than the usual apps like MS Office, iStat Menus and VMWare, which are also installed in my old MacBook Air and Pro running Maverick.

    Yosemite System Report also shows that the USB drive is connected at high speed:

    USB 3.0 FD:
    Speed: Up to 5 Gb/sec
    Manufacturer: PNY Technologies
    Location ID: 0x15200000 / 12
    Current Available (mA): 900
    Current Required (mA): 504
    Capacity: 256 GB (255,999,344,640 bytes)
    Removable Media: Yes

    Internal Memory Card Reader:
    Product ID: 0x8406
    Vendor ID: 0x05ac (Apple Inc.)
    Version: 8.20 Serial Number: 000000000820
    Speed: Up to 5 Gb/sec
    Manufacturer: Apple


    Do you also use CCC? If yes, can you boot up from the external drive containing the image and was it fast?
     
  4. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #4
    I tested all my USB 3.0 drives on my friend MacBook Pro 13" Retina (same model, but he has more SSD) and... same thing. SLOW SPEED.

    Here's the screenshot for one of the drive (256GB PNY USB 3.0), but same goes with the other one:

    [​IMG]

    For the PNY drive, others have posted in Amazon really fast speed on Windows machine AND (apparently) older MacBook.

    So those who have the latest MacBook Pro, do you have the same issue? Trying to determine if my MacBook Pro have a bad controller or BOTH USB ports.
     
  5. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #5
    I am wondering if those who have fast speed on USB drive have Maverick. All machines are Yosemite and I don't have a Maverick machine to test.

    And yes, I've tried everything, from OSX reinstall to SMC resets and what not.
     
  6. Essenar macrumors 6502a

    Joined:
    Oct 24, 2008
    #6
    I've noticed issues with my USB port too. Whenever I wake the laptop up from sleep, the USB port is incredibly slow. If I play a video from my Supersonic Xpress (which is fast enough of a USB 3.0 drive that I was able to run Windows 7 from it as a Live USB on a Windows laptop, and even play FFXIV from without lag), the video has constant freezing and hiccups.

    However, if I force eject it and plug it back in, it's back to somewhat reasonable speeds. Writing to it is super fast. I can literally copy gigabytes of data in seconds but when I try to read from it, AFTER sleep, it runs super slow.
     
  7. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #7
    Well, I just bought an rMBP and haven't noticed any USB3 speed problems, and it came pre-installed with Yosemite 10.10, which I updated to 10.10.3 beta straight away (I had migrated my entire setup from my iMac to the rMBP so I have identical setups with apps/extensions, so the Mac App Store didn't give me the option to install 10.10.2).

    If your Mac is still covered under applecare or warranty, then I would setup a genius appointment..
     
  8. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #8

    Supposedly, I can also boot and recover my files with TM:

    https://support.apple.com/en-us/HT4718


    What am I really missing with CCC?
     
  9. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #9
    Having a bootable clone courtesy of CCC means you can run your mac straightaway rather than having to restore from a time machine backup, which could take an hour.
     
  10. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
  11. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #11
    Nah, the most experienced ones are the mods and the ones with the G-titles (especially the G5 ones, and beyond, like Core, Nehalem, Westmere...) :D
     
  12. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #12
    Just a quick update:

    I have a spare 5400 RPM HDD and put it in a USB 3.0 external HDD enclosure. I don't know what speed is expected, but with BlackMagic Disk Speed test I got 50 MBps speed. Is this normal?

    I did a CCC clone from my 2014 rMBP Pro to this HDD via USB 3.0. I can boot up from the external drive, though it's still slow. It took 5 minutes from OFF state to the OSX desktop where all the icons and the taskbar are drawn and ready.
     
  13. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #13
    Actually, you should be getting closer to 90 MBps, with a 5400 RPM 2.5" drive...
     
  14. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #14
    A 250GB 5400rpm HDD should perform about that speed.

    However, a 1TB one (or even a 500GB) should perform at around 105-110MB/s (that's what I get with a Western Digital Scorpio Blue 1TB 5400rpm HDD).
     
  15. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #15
    [MOD NOTE]
    Thread has been cleaned up, quite a number of posts have been removed unfortunately but due to the rules violations it had to be done.

    Please stay on topic and avoid attacking members. as per our Rules for Appropriate Debate
     

Share This Page