2014 MBPr 15" PCIe SSD failure

Discussion in 'Mac Basics and Help' started by patent10021, Jul 12, 2017.

  1. patent10021, Jul 12, 2017
    Last edited: Jul 12, 2017

    patent10021 macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #1
    So a couple of days ago I woke up and couldn't boot my MBPr. Got the folder with question mark cause it can't find the boot directory. That can either mean it can't find the hard drive or the Operating System data on the hard drive is somehow corrupted. I'm surprised that an SSD this new would fail. I think I have tried everything from the MacOS Support manuals to deeper forensic techniques. I have not attempted any hardware forensics yet because I'm in Japan and no one has SSD PCIe enclosures or disks. I have to get those from iFixit, OWC, MacSales or ebay etc. I'll be going home next week so I thought I'd try all the hardware troubleshooting when I can purchase a PCIe enclosure.


    I am pretty sure I have tried all recovery disk and Disk Utility options. Disk Utility says the 1TB Apple SSD partition map is ok and no errors. I have tried Terminal recovery techniques using diskutil, dd, rdisk, asr, etc. I also tried copying files from the source disk disk0s2 (MacOS Sierra SSD) -> disk15s1 (external Seagate) dd bs=262144 if=/dev/rdisk0s2 of=/dev/rdisk15s1 conv=noerror.sync.

    A problem with dd is that unless you have pv installed via brew or something you cannot view progress so I have no idea what is going on therefore I had to stop it prematurely as I wanted to use that spare SATA HD to install MacOS so I could use my MB do get work done. It did say there were xx amount of sectors transferred though. But since I stopped it prematurely there was no browsable file system to even check.

    Since a complete 1TB SSD PCIe kit costs about $700 including enclosure for the older I was considering just buying a new small space grey MB with 256GB SSD to do some work and then later swap PCIe SSDs for testing or using Target Mode for further testing.

    I noticed with SSD forensics that SSDs do not show a filesystem in diskutil/Disk Utility like SATA disks. They show mount points and other info. Therefore I was unable to mount my partitions. Is there anything I can do with the disk UUID?

    The structure was:
    disk0 - Apple SSD
    disk0s1 - EFI
    disk0s2 - 1TB
    disk0s3 - 500GB


    This external 2TB Seagate disk I'm using is partitioned with 500GB MacOS / 1.5TB empty partition. What are my other trouble shooting options?

    mid 2014 MBPr 15" 11,2
    MacOS Sierra

    APPLE SSD
    Code:
    Name :     APPLE SSD SM1024F Media
    
        Type :     Disk
        Partition Map Scheme :     GUID Partition Table
        Disk Identifier :     disk0
        Media Name :     APPLE SSD SM1024F Media
        Media Type :     Generic
        Connection Bus :     PCI
        Device Tree :     IODeviceTree:/PCI0@0/RP05@1C,4/SSD0@0/PRT0@0/PMP@0
        Writable :     Yes
        Ejectable :     No
        Location :     Internal
        Solid State Disk :     Yes
        Total Capacity :     1 TB (1,000,555,581,440 Bytes)
        Disk Number :     0
        Partition Number :     0
        S.M.A.R.T. Status :     Verified
        Raw Read Error :     000000000000
        Reallocated Sector Count :     000000000000
        Power On Hours :     000000003A05
        Power Cycle :     000000000A4F
        Unexpected Power Loss :     0000030A8654
        Temperature :     0040000D0024
        UDMA CRC Error (PATA only) :     000000000000
    
    
    Boot partition.
    
    Name :     disk0s2
    
        Type :     Partition
        Disk Identifier :     disk0s2
        Mount Point :     Not mounted
        Partition Type :     7C3457EF-0000-11AA-AA11-00306543ECAC
        Connection Bus :     PCI
        Device Tree :     IODeviceTree:/PCI0@0/RP05@1C,4/SSD0@0/PRT0@0/PMP@0
        Writable :     Yes
        Capacity :     999.69 GB (999,690,465,280 Bytes)
        Owners Enabled :     No
        Can Turn Owners Off :     No
        Can Be Formatted :     No
        Bootable :     No
        Supports Journaling :     No
        Journaled :     No
        Disk Number :     0
        Partition Number :     2
    Boot Partition
    Code:
    Device Identifier:        disk0s2
    
       Device Node:              /dev/disk0s2
       Part of Whole:            disk0
       Device / Media Name:      Customer
       Volume Name:              Not applicable (no file system)
       Mounted:                  Not applicable (no file system)
       File System:              None
       Partition Type:           7C3457EF-0000-11AA-AA11-00306543ECAC
       OS Can Be Installed:      No
       Media Type:               Generic
       Protocol:                 PCI
       SMART Status:             Verified
       Disk / Partition UUID:    0682AA6A-F562-454A-8569-EDFF4ADC061A
       Total Size:               999.7 GB (999690465280 Bytes) (exactly 1952520440 512-Byte-Units)
       Volume Free Space:        Not applicable (no file system)
       Device Block Size:        512 Bytes
       Read-Only Media:          No
       Read-Only Volume:         Not applicable (no file system)
       Ejectable:                No
       Whole:                    No
       Internal:                 Yes
       Solid State:              Yes
    dd volume list
    Code:
     
     #:                       TYPE NAME                    SIZE       IDENTIFIER
    
       0:      GUID_partition_scheme                        *1.0 TB     disk0
       1:                        EFI EFI                     209.7 MB   disk0s1
       2: 7C3457EF-0000-11AA-AA11-00306543ECAC               999.7 GB   disk0s2
       3: 5361644D-6163-11AA-AA11-00306543ECAC               655.4 MB   disk0s3
    
    /dev/disk1
    
       #:                       TYPE NAME                    SIZE       IDENTIFIER
    
       0:      GUID_partition_scheme                        *2.0 TB     disk1
       1:                        EFI EFI                     209.7 MB   disk1s1
       2:                  Apple_HFS MACOS                   499.5 GB   disk1s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
       4:                  Apple_HFS BACKUP                  1.5 TB     disk1s4
    I had my display replaced at Apple Osaka because of a broken screen due to impact. All seemed ok since data and screen were fine after the replacement. But a short while after the replacement there were a few times when I noticed the occasional line across the display during boot. I remember not feeling comfortable with the service because of those glitches and also when I got the MB back because it wasn't cleaned. I have always got it cleaned in Vancouver to the point where it looked brand new. I was thinking maybe they didn't reattach a connector properly. I've also read that impacted displays can sometimes affect logic boards or disks. Maybe it was just bad luck.

    Since this is a new install and I need Xcode anyway I will reinstall Xcode / CLTools then Brew then PV and I will run dd copy again to new partition on this external SATA HD and I will then be able to view the copy progress. Does anyone know how long it will take for 1TB?

    Also is there a way using dd to copy just a directory i.e. /Downloads even though I cannot see the filesystem on the failed partition?

    Also should I open up the MBPr and check if there is a loose connector?
     
  2. patent10021, Jul 13, 2017
    Last edited: Jul 13, 2017

    patent10021 thread starter macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #2
    Interesting. I'm not sure if it happened while I was disabling - enabling Finder side bar items like DVDs, disks, Servers etc but the older HD called "Server HD" showed up on the desktop of this new temporary Sierra desktop. I want to access this directory and get to the Download and Documents folders. I gave myself and administrator privileges but I still cannot access it. Should I first copy those two folders to my empty partition for backup?

    Any suggestions?

    EDIT: Nevermind! It seems it took a while for the permissions to take affect. I can access all!

    Amazing. What the heck happened?
     

    Attached Files:

Share This Page