(2014) No sound every time monitors sleep?

Discussion in 'Mac mini' started by bulldog212, Nov 1, 2014.

  1. bulldog212 macrumors newbie

    Joined:
    Oct 25, 2014
    #1
    I have already disabled the mini from sleeping because that is a nightmare to wake back up, sometimes having to power off/on. So this is just when I let my displays go to sleep. Every time I wake them up I notice the sound icon in the status bar has gone gray. Reboot/logoff does not fix this, I have to pull out my mini and unplug/replug my 3.5 speaker jack and it's fine again. Never goes out during use. Does OS X have some sort of low power mode that engages between full sleep and full on? This "Macs just work" line hasn't been my experience so far. Any ideas?
     
  2. stevemr123 macrumors member

    Joined:
    May 27, 2010
    #2
    What kind of display connection are you using? If you are using HDMI or DisplayPort, that may cause the problem, since these can carry digital audio as well as the video signal. It does not matter if your display has no speaker connected, the operating system may still be routing the audio to your display. Volume control is not enabled if the audio output is digital, that's why the volume control icon is grayed out.

    If you press option (alt) while you click on the volume icon, you can change the default output from your display to the built in analog output.

    Hope this helps.
     

    Attached Files:

  3. bulldog212 thread starter macrumors newbie

    Joined:
    Oct 25, 2014
    #3
    Thank you. I had already unplugged/replugged my speakers 3.5mm so I can't see what was chosen when grayed out but it is showing both monitors as sound output options so that is probably it. Why does the OS flip my sound output to the components that are sleeping? That makes zero sense. How do I force it to always go to 3.5mm out? Or maybe I'll have to plug my speakers into one of the monitors, which seems silly but may be a workaround.
     
  4. bulldog212 thread starter macrumors newbie

    Joined:
    Oct 25, 2014
    #4
    Plugging my speakers into one of the monitors is absolutely not a viable option. Even though it works, the status bar icon is grayed out and my volume control from the keyboard stops functioning. Do I REALLY need to buy TWO MORE adapters to go DP-to-DVI instead? How dumb.
     
  5. stevemr123 macrumors member

    Joined:
    May 27, 2010
    #5
    You can change the default sound output in two ways:

    - Alt+Click on the speaker icon and select the desired output
    - Open the "Audio MIDI Setup" and right click on the desired output in the left panel - you can set an output as the default there ("Use this device for sound output").
     

    Attached Files:

Share This Page