2015 13'' rMBP Severely Lagging on External Display

Discussion in 'MacBook Pro' started by evrard, Apr 29, 2015.

  1. evrard macrumors regular

    evrard

    Joined:
    Oct 20, 2014
    Location:
    Brooklyn
    #1
    I know there is a huge thread on this but am trying to avoid reading through thousands of replies.

    My 2015 13'' rMBP running OS X 10.10.3 severely lags when I connect it to an scaled external display. Resetting the pram only made the issue worse (could just be me thinking it got worse, haha). I'm not sure what else I can do.

    The lagging is so bad that when I have it scaled to 4K native resolution typing in iMessage will be sentences behind input.
     
  2. ByDesign macrumors newbie

    Joined:
    Nov 28, 2014
    #2
    Which monitor and how are you connected? Also, are you running without any lag when you are on just your macbook pro?
     
  3. evrard thread starter macrumors regular

    evrard

    Joined:
    Oct 20, 2014
    Location:
    Brooklyn
    #3
    Great questions. I'm connecting to a Samsung 4k UD590, my previous 13'' connect fine to the monitor with no lagging. When I am just using the MBP I notice carry-over lag, meaning it will lag until I restart.
     
  4. ByDesign macrumors newbie

    Joined:
    Nov 28, 2014
    #4
    That should be the same panel as my ASUS pb287q. I assume you have it connected with a Thunderbolt to Display port Adapter. If not, this is the one I'm using with great success. http://www.monoprice.com/Product?p_id=12001 . I did need to change my Display Port option from 1.1 to 1.2 on the monitor. I still get occasional slow downs and such but I'm very happy. We should be able to get you running smoother but who knows it may take 10.10.4 to fix things.
     
  5. ByDesign, Apr 29, 2015
    Last edited: Apr 29, 2015

    ByDesign macrumors newbie

    Joined:
    Nov 28, 2014
    #5
    I'm just going to throw out some ideas and maybe one will help.

    1.) To get 60 Hz you must be running a DisplayPort 1.2 Male to Mini DisplayPort Male Cable.

    2.) HDMI will work but will only run at 30 Hz. It will feel like the Macbook Pro is dropping frames but the screen should still look beautiful.

    3.) When connecting to the monitor (and you have the Macbook Pro lid open) you get 2 choices under display options. Pick optimize for your Samsung monitor and not the internal retina display. Then choose scaled and select "Looks like 1920x1080". Close the lid on the Macbook. This setting looks very nice on mine.

    4.) Macbook Pro must be plugged in.

    5.) Double check that your monitor is running 60 Hz. by looking in your Samsung's On Screen Menu.

    6.) Make sure Display Port option is changed from 1.1 to 1.2 on the monitor.

    7.) Even if everything works as it should there still may be some issues that are annoying.
     

Share This Page